Opened 11 years ago

Closed 10 years ago

#501 closed defect/bug (fixed)

compile error in gui_internal.c - HAVE_API_WIN32_BASE used before #include <config.h>

Reported by: stressedpiper Owned by: cp15
Priority: major Milestone:
Component: gui/internal Version: git master
Severity: Keywords:
Cc:

Description

Using win32, compilation of gui_internal.c fails on some platforms due to undefined functions not being picked up from within windows.h

The root cause seems to be that HAVE_API_WIN32_BASE is being used before being defined/included from "config.h". That is, currently

#ifdef HAVE_API_WIN32_BASE #include <windows.h> #endif #include "config.h"

instead of

#include "config.h" #ifdef HAVE_API_WIN32_BASE #include <windows.h> #endif

Change History (1)

comment:1 Changed 10 years ago by kazer

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.