Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#522 closed defect/bug (fixed)

navit (navit-svn-2894.apk ) crash on loading libraries

Reported by: balla Owned by: cp15
Priority: blocker Milestone:
Component: port/android Version: git master
Severity: Keywords:
Cc: frenzel, edwintorok@…

Description

On start Navit tha application crash, in the log there are a errors on library check. snip of log:

E/navit ( 864): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libgraphics_android.so', Error 'Cannot find library' E/navit ( 864): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libvehicle_android.so', Error 'Cannot find library' E/navit ( 864): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libgui_internal.so', Error 'Cannot find library' E/navit ( 864): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libmap_textfile.so', Error 'Cannot find library' E/navit ( 864): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libmap_binfile.so', Error 'Cannot find library' E/navit ( 864): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libosd_core.so', Error 'Cannot find library'

Attachments (4)

logs.txt (4.0 KB) - added by balla 10 years ago.
logs of crash
Frenzels-log.txt (4.6 KB) - added by frenzel 10 years ago.
navit.txt (2.7 KB) - added by jan 10 years ago.
kabinials_log.txt (2.9 KB) - added by kabinial 10 years ago.

Download all attachments as: .zip

Change History (21)

Changed 10 years ago by balla

logs of crash

comment:1 Changed 10 years ago by balla

  • Summary changed from navit (navit-svn-2866.apk ) crash on loading libraries to navit (navit-svn-2866.apk ) crash on loading libraries ( htc magic)

comment:2 Changed 10 years ago by frenzel

  • Cc frenzel added

I seem to have exactly the same problem.

Changed 10 years ago by frenzel

comment:3 Changed 10 years ago by frenzel

  • Priority changed from major to blocker

By the way for me it is not on a HTC Magic but on a HTC Hero.

comment:4 Changed 10 years ago by frenzel

As additional information the "cannot find lib files" are all in the exact same dir as the error line notes. So the files itself are NOT missing.

If I need to check anything else then please note it.

comment:5 Changed 10 years ago by jan

  • Summary changed from navit (navit-svn-2866.apk ) crash on loading libraries ( htc magic) to navit (navit-svn-2894.apk ) crash on loading libraries

I can confirm the same bug on my T-Mobile Pulse (Huawei U8220) with navit-svn-2894

Changed 10 years ago by jan

comment:6 Changed 10 years ago by kabinial

The same problem on my HTC Hero (android 1.5): "crash on loading libraries" navit-current.apk 06-Jan-2010 02:19

Changed 10 years ago by kabinial

comment:7 Changed 10 years ago by me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6

Same problem here, I bisected this problem down to this commit: r2849 | martin-s | 2009-12-06 13:32:53 +0200 (Sun, 06 Dec 2009) | 2 lines

Fix:Build:Changed linking of modules for android due to recent change in loading behaviour

If I manually revert that commit, on top of r2897 for example, then build it, and install it, it works. The .apk from the download, or a manually built unpatched r2897 doesn't work!

I am using android ndk 1.5_r1, and android sdk 1.5_r3. I don't know what build that commit was meant to fix, but if it requires a newer NDK/SDK then it won't work on the HTC Hero.

comment:8 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawn8bcw2jum5dfxu0yhltyygwcrht9trz1i

Would you be kind enough to provide the APK with the 2 lines reverted so others like myself can test?

comment:9 Changed 10 years ago by me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6

  • Cc https://me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6 added

I've uploaded it here:

http://www.fileden.com/files/2009/9/1/2561232/navit-svn-2897.apk

There are several issues with that apk though, it crashes quite often (usually after about a minute after startup). I think it runs out of memory and gets killed, didn't have time to track down what the problem is yet, so use that apk at your own risk ;)

comment:10 Changed 10 years ago by me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6

Actually the problem is that support/wordexp.c:wordexp returns an uninitialized value, and that libnavit.so must not depend on libintl.so (libintl can be linked statically into it).

This patch fixes the problem: diff --git a/trunk/navit/configure.in b/trunk/navit/configure.in index 4d83836..e8cbc34 100644 --- a/trunk/navit/configure.in +++ b/trunk/navit/configure.in @@ -106,7 +106,7 @@ linux*_android)

speech_android=yes; speech_android_reason="host_os is android" MODULE_LDFLAGS="-module -Xcompiler -nostdlib" MODULE_LIBADD="-llog"

  • NAVIT_MODULE_LDFLAGS="$MODULE_LDFLAGS -L\$(top_builddir)/navit -lnavit"

+ NAVIT_MODULE_LDFLAGS="$MODULE_LDFLAGS"

;;

esac if test "x$win32" = "xyes"

@@ -650,7 +650,7 @@ AC_SUBST(MOFILES)

AC_SUBST(POFILES) AC_SUBST(POIFILES) AM_GNU_GETTEXT_VERSION

-AM_GNU_GETTEXT(use-libtool, need-ngettext, \$(top_builddir)/intl/) +AM_GNU_GETTEXT(no-libtool, need-ngettext, \$(top_builddir)/intl/)

AC_SUBST(LIBINTL) AC_SUBST(LTLIBINTL) if test x"$LIBINTL" != "x" ;then

diff --git a/trunk/navit/navit/support/wordexp/wordexp.c b/trunk/navit/navit/support/wordexp/wordexp.c index bacaea5..868b482 100644 --- a/trunk/navit/navit/support/wordexp/wordexp.c +++ b/trunk/navit/navit/support/wordexp/wordexp.c @@ -83,7 +83,7 @@ int

wordexp(const char *words, wordexp_t *we, int flags) {

int i;

  • int error;

+ int error = 0;

char *words_expanded;

#ifdef HAVE_API_WIN32_BASE

glob_t pglob;

comment:11 Changed 10 years ago by me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6

And here is the .apk that works on my HTC hero based on SVN r2914 and the above patch: http://www.fileden.com/files/2009/9/1/2561232/Navit-debug.apk

comment:12 Changed 10 years ago by me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6

  • Cc https://me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6 removed

comment:13 Changed 10 years ago by me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6

  • Cc edwintorok@… added

comment:14 Changed 10 years ago by kazer

  • Resolution set to fixed
  • Status changed from new to closed

Patch from ticket #538 applied in rev2933, thank you the_guy_with_no_nickname :)

comment:15 Changed 10 years ago by me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6

Thanks. BTW my name is edwin, I used openid login. Where can I set a nickname? :)

comment:16 Changed 10 years ago by kazer

You should be able to set in in the preferences page : http://trac.navit-project.org/prefs

comment:17 Changed 10 years ago by me.yahoo.com/a/hthlykcvonrgunec9ub0cbz2zzjwdg10#c2fd6

I did, and it shows me "logged in as edwin". Doesn't seem to have an effect on the comments though.

Note: See TracTickets for help on using tickets.