Opened 11 years ago

Closed 10 years ago

#525 closed defect/bug (fixed)

Crash on android

Reported by: skliarie Owned by: cp15
Priority: major Milestone:
Component: port/android Version: git master
Severity: Keywords:
Cc:

Description

Navit navit-svn-2876.apk crashes on android-for-freerunner. From logcat it looks like some libraries were not included:

E/navit ( 1608): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libgraphics_android.so', Error 'Cannot find library' E/navit ( 1608): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libvehicle_android.so', Error 'Cannot find library' E/navit ( 1608): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libgui_internal.so', Error 'Cannot find library' E/navit ( 1608): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libmap_textfile.so', Error 'Cannot find library' E/navit ( 1608): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libmap_binfile.so', Error 'Cannot find library' E/navit ( 1608): navit:plugin_load:can't load '/data/data/org.navitproject.navit/lib/libosd_core.so', Error 'Cannot find library'

Find attached full logcat.

Attachments (1)

navit_2876_crash.txt (12.8 KB) - added by skliarie 11 years ago.
logcat

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by skliarie

logcat

comment:1 Changed 10 years ago by kazer

  • Resolution set to fixed
  • Status changed from new to closed

It was caused by a broken package (missing libs, as stated in your report) and should be fixed now. If not, please reopen.

Thanks.

Note: See TracTickets for help on using tickets.