Opened 10 years ago

Closed 10 years ago

#529 closed defect/bug (fixed)

[gui_internal] Segfault when using menu button "Show on map"

Reported by: pini Owned by: cp15
Priority: blocker Milestone:
Component: gui/internal Version: git master
Severity: Keywords:
Cc:

Description

Hi,

This simple sequence makes Navit segfault:
1- clic a point on the map
2- menu Action
3- globe button (selected coordinates)
4- Show on map
=> segfault

This segfault is caused by a null pointer at gui_internal.c:2122 (w == NULL).

AFAICT the navit.xml file is correct: no difference with navit_shipped.xml but the mapsets.

See also http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=562591.

Thanks.

Attachments (1)

navit-529.patch (528 bytes) - added by pini 10 years ago.
Fix ticket #529

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by pini

Fix ticket #529

comment:1 Changed 10 years ago by pini

Hi,

Actually it seems that's a side effect of svn rev2790 "Add:core:Implement new in command.c". The "Show on map" option shouldn't appear in this use case and seems introduced there because of an inappropriate handling in navit:command_call_function.

Adding an "else" at navit/command.c:387 restores the correct behavior. Patch attached.

Thanks,

comment:2 Changed 10 years ago by horwitz

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in revision 2896.

Note: See TracTickets for help on using tickets.