Opened 10 years ago

Closed 10 years ago

#532 closed defect/bug (duplicate)

Crash when entering the menu (upon clicking on the map)

Reported by: joysfera.blogspot.com Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc: pstehlik@…

Description

This crash started occurring sometime in November '09.

#0  0x00273f43 in strlen () from /lib/tls/i686/cmov/libc.so.6
#1  0x08057039 in xml_parse_text (document=0x0, data=0x80e1f98, start=0xea3650 <gui_internal_html_start>, 
    end=0xea3420 <gui_internal_html_end>, text=0xea3100 <gui_internal_html_text>) at xmlconfig.c:864
#2  0x00e9f802 in gui_internal_html_menu (this=0x80e1f98, document=0x0, anchor=0xeab88b "Main Menu") at gui_internal.c:3941
#3  0x00ea9fb9 in gui_internal_menu_root (this=0x80e1f98, p=<value optimized out>, ignore=<value optimized out>)
    at gui_internal.c:3949
#4  gui_internal_cmd_menu (this=0x80e1f98, p=<value optimized out>, ignore=<value optimized out>) at gui_internal.c:4008
#5  0x00eaa3da in gui_internal_button (data=0x80e1f98, pressed=0, button=1, p=0xbffff1d4) at gui_internal.c:4209
#6  0x0805a751 in callback_call (cb=0x80e7098, pcount=3, p=0xbffff130) at callback.c:172
#7  0x0805a858 in callback_list_call_attr (l=0x80a08f0, type=attr_button, pcount=3, p=0xbffff130) at callback.c:219
#8  0x0805a9af in callback_list_call_attr_args (cbl=0x80a08f0, type=attr_button, count=0) at callback.c:235
#9  0x00113a78 in graphics_sdl_idle (data=0x80a1210) at graphics_sdl.c:2059
#10 0x0058153c in g_timeout_dispatch (source=0x80c7808, callback=0, user_data=0x80a1210)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:3396
#11 0x00580e88 in g_main_dispatch (context=0x80c7868) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#12 IA__g_main_context_dispatch (context=0x80c7868) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#13 0x00584730 in g_main_context_iterate (context=0x80c7868, block=<value optimized out>, dispatch=1, self=0x809b8b8)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#14 0x00584b9f in IA__g_main_loop_run (loop=0x809c1b8) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2799
#15 0x08058976 in event_glib_main_loop_run () at event_glib.c:34
#16 0x0805cdde in event_main_loop_run () at event.c:36
#17 0x080527ac in main_real (argc=3, argv=0xbffff524) at start_real.c:178
#18 0x080524fb in main (argc=3, argv=0xbffff524) at start.c:25

Attachments (1)

myconfig.tgz (20.0 KB) - added by joysfera.blogspot.com 10 years ago.
it's crashing with this config file

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by joysfera.blogspot.com

it's crashing with this config file

comment:1 Changed 10 years ago by kazer

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #506

Note: See TracTickets for help on using tickets.