Opened 11 years ago

Closed 11 years ago

#550 closed defect/bug (fixed)

Zoom In/Out buttons invisible in internal GUI

Reported by: mvglasow Owned by: kazer
Priority: minor Milestone:
Component: port/wince Version: git master
Severity: Keywords:
Cc:

Description

When using the internal GUI on WinCE, the Zoom In/Out? buttons are invisible on startup. Tapping where the button should be will, however, start the desired zoom action and the buttons will appear. Also, bringing up the menu and returning to the map will show the buttons. Tested on WinCE SVN build 2952.

Change History (5)

comment:1 Changed 11 years ago by mvglasow

excerpt from my navit.xml:

<osd enabled="yes" type="button" x="0" y="32" command="zoom_out()" src="gui_zoom_out_32_32.png"/>
<osd enabled="yes" type="button" x="-32" y="32" command="zoom_in()" src="gui_zoom_in_32_32.png"/>

comment:2 Changed 11 years ago by tiiiim

This also happens for me, but only sometimes! Haven't worked out a pattern yet.

I'm using latest SVN build 2964 on Ubuntu Karmic, Acer One netbook.

comment:3 Changed 11 years ago by mvglasow

Looking at osd_core.c, I see that for pretty much all OSD items the init method ultimately calls the related draw method, EXCEPT for buttons. Is there any particular reason for this?

I suspect this missing call to be the culprit. tiiiim's symptoms may be because sometimes he's getting some events that would by themselves call osd_button_draw and the buttons will appear, sometimes there is no such event and the buttons hence will not appear.

Unfortunately I don't have a build environment set up, so I can't easily test this. Maybe someone with the build env can just drop a call to osd_button_draw into osd_button_init (at the very end) and see if that changes anything.

comment:4 Changed 11 years ago by kazer

  • Component changed from osd/core to port/wince
  • Owner changed from Singesang to kazer
  • Status changed from new to assigned

I was able to reproduce the bug, mvglasow, you seem to be right..

comment:5 Changed 11 years ago by kazer

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in rev 3002. Thanks mvglasow for reporting and tracking down this bug.

Note: See TracTickets for help on using tickets.