Opened 11 years ago

Closed 9 years ago

#564 closed defect/bug (fixed)

latest svn android crashes with bigger maps

Reported by: casula Owned by: cp15
Priority: major Milestone: version 0.2.1
Component: port/android Version: git master
Severity: Keywords: android crash big map routing engine memory
Cc: http://wiki.navit-project.org/index.php/user:florent, http://wiki.navit-project.org/index.php/user:florian, heinold@…

Description

testet on motorola milestone 2.0.1 testet with two maps: small (~50mb) : seems to work fine big (~500mb - germany): crashes after ~30s no matter what doing

see log attached

Attachments (2)

navit_log.txt (48.2 KB) - added by casula 11 years ago.
alogcat
CrashLog.txt (8.2 KB) - added by www.google.com/accounts/o8/id?id=aitoawndc28bpe_rpfzr74o7foz-afjyl-or2c4 10 years ago.
Crash log when using a large .bin map and GPS

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by casula

alogcat

comment:1 Changed 11 years ago by thomas0782

This behavior also occurs on Windows Mobile. Experienced it on my own, but also other users mentioned this:

http://sourceforge.net/projects/navit/forums/forum/512960/topic/3552656

comment:2 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawndc28bpe_rpfzr74o7foz-afjyl-or2c4

I can confirm the problem:


Issue: Large .bin map (around 100 MB) + GPS enabled --> Crash Small .bin map (around 40 MB) + GPS enabled --> No crash Large .bin map (around 100 MB) + GPS disabled --> No crash

The crash seems to happen in the moment navit tries to focus on the current gps location, right after the start of the application. The log is attached.


Device: Zii Egg 256MB RAM


Android version: 1.6


This problem exists with navit-svn-3195.apk and navit-svn-3212.apk (did not check any older versions) downloaded from http://download.navit-project.org/navit/android/svn/ .


Thanks a lot for your immense work- this is a really great software!

Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawndc28bpe_rpfzr74o7foz-afjyl-or2c4

Crash log when using a large .bin map and GPS

comment:3 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawndc28bpe_rpfzr74o7foz-afjyl-or2c4

UPDATE: In my case, I can avoid the crash by:

1) Starting navit (before switching on the GPS)
2) Go to "Settings" --> "Rules" --> Disable "Map follows Vehicle"
3) Switch on GPS

If you want to center your map according to your GPS location:
4) Go to "Action" --> Click on GPS Icon (car) --> Click on "View on map"

Well, not a very elegant work-around, but better than nothing...

It's funny though that the re-centering of the map triggered by the option "Map follows Vehicle" seems to crash whereas the re-centering by the option "View on map" seems to be fine. What's exactly the difference (at start-up) between those two?
Second question: Is there a way to disable to option "Map follows Vehicle" by default (in the navit.xml) until there is a fix for this issue?

comment:4 follow-up: Changed 10 years ago by kazer

  • Milestone set to version 0.2.0

To disable "Map follows Vehicle" : try setting <vehicle follow=0 > in navit.xml

comment:5 in reply to: ↑ 4 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawndc28bpe_rpfzr74o7foz-afjyl-or2c4

Replying to http://wiki.navit-project.org/index.php/user:kazer:

To disable "Map follows Vehicle" : try setting <vehicle follow=0 > in navit.xml

Thanks for your reply!
I adjusted the line:

<vehicle name="Local GPS" profilename="car" enabled="yes" active="1" source="android:" follow="0">

accordingly to your suggestion. Strange enough, Navit still starts and re-centers around the GPS-location. Also the GUI option "Map follows Vehicle" is still activated. My navit.xml is read by Navit since I entered a custom centering point for the application-start and it still centers around this point (before re-centering around the GPS-location). But surprise: Re-centering at start-up now works with the 100MB map (revision 3270). So just to test if it was the "follow=0" change which made it work I reverted back to "follow=1" and: The re-centering at start-up still worked! Is this due to the new revision I have installed? Or just by chance?

comment:6 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawlqblcgamwotrrv6lcj0zouv7zolwq7ulg

I can confirm this issue on my HTC Magic with Android 2.1 If I use a map from the area wich is about 50mb I can start Navit and navigate. It all works fine. If I use the Germany map Navit will crash when I set a certain place as location. Disabling the follow setting in the menu does not prevent the crash. Same for turning off GPS. When I use a navit.xml it will crash no matter what I write in there.

comment:7 Changed 10 years ago by florent

  • Cc http://wiki.navit-project.org/index.php/user:florent added
  • Keywords routing engine memory added

I have exactly the same effect with revision 3495 on archos 5 IT (with 256MB RAM) : crash at start-up only with gps AND a big map (whole France) I think this is the routing engine that have a bug: -when gps off and set manually a position, it crashes -when uninstall (for erasing navit datas, especially destination) and next install navit, it works (but just follow position, without route) Thanks a lot for this great soft

comment:8 Changed 10 years ago by florent

Just an idea, maybe an overcommit memory issue (navit stopped by android OOM Killer ?). If right, a solution could be the onLowMemory callback.

comment:9 Changed 10 years ago by florian

It seems to look like this. I enabled Swap on Cyanogen 6. I took the Germany map. I set a start point and an ending point, it already showed me the route. It was about 600km Then I waited for a GPS fix and tada, no crash. I did not drive yet but I guess it will work. I could also scroll on the map. Slow as always but for navigation speed it is still enough. I did not test with disabled swap, although but I guess it would crash then. First I try an even bigger map.

Is it possible for us to have a testbuild with the onLowMemory callback?

comment:10 Changed 10 years ago by florian

  • Cc http://wiki.navit-project.org/index.php/user:florian added

comment:11 Changed 9 years ago by woglinde

  • Cc heinold@… added

Hi,

still an bug even with the android version from market? If not I will close the bug the next time I look at it.

Bye Henning

comment:12 Changed 9 years ago by korrosa

  • Resolution set to fixed
  • Status changed from new to closed

Assuming fixed. Please re-open if you find the same problem.

Note: See TracTickets for help on using tickets.