Opened 10 years ago

Closed 10 years ago

#569 closed defect/bug (fixed)

Navit on Android crashes on Freerunner if Map is available; loads fine without maps

Reported by: www.google.com/accounts/o8/id?id=aitoawm-dibaa_pzfqwtdgn-ruv8nxiqyta1aoy Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc: skliarie@…

Description

Running Navit svn 3230 (armv4t) and android-on-freerunner-cupcake-0.2.0-RC1. If I remove my map from /sdcard navit starts fine and only asks me if I want to download TTS (which doesn't work if I accept it). Everything is fine, just no maps ... If I copy a map to /sdcard, navit starts up with a black screen and is killed at some point. What strangely enough works if one has a map, also shown within the navit maps menu as active, but the area on display is not within the maps area. but if one tries to have a city which is in the maps shown, navit is again killed. So it may be a rendering issue?

Attachments (2)

bernd.txt (9.9 KB) - added by www.google.com/accounts/o8/id?id=aitoawm-dibaa_pzfqwtdgn-ruv8nxiqyta1aoy 10 years ago.
logcat
navit-svn_3250_armv4t.logcat (10.0 KB) - added by www.google.com/accounts/o8/id?id=aitoawm-dibaa_pzfqwtdgn-ruv8nxiqyta1aoy 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawm-dibaa_pzfqwtdgn-ruv8nxiqyta1aoy

logcat

comment:1 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawm-dibaa_pzfqwtdgn-ruv8nxiqyta1aoy

  • Summary changed from Navit crashes on Freerunner if Map is available; loads fine without maps to Navit on Android crashes on Freerunner if Map is available; loads fine without maps

comment:2 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawmt_2jzc7qtwztzirkgwbdkyndcgifaswg

  • Cc skliarie@… added

comment:3 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawndc28bpe_rpfzr74o7foz-afjyl-or2c4

Hi,

Have you tried different map sizes? Could be bug http://trac.navit-project.org/ticket/564 ...

Cheers.

comment:4 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawm-dibaa_pzfqwtdgn-ruv8nxiqyta1aoy

@ skliarie: I just tried, but Mapsize does not matter (44Mb doesn't work). I also installed svn3250 but the error is still there. I checked the logcat (see file attached and the only error I can see is the following:

D/dalvikvm( 1135): +++ not scanning '/system/lib/libwebcore.so' for 'SizeChangedCallback?' (wrong CL) D/dalvikvm( 1135): +++ not scanning '/system/lib/libmedia_jni.so' for 'SizeChangedCallback?' (wrong CL)

Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawm-dibaa_pzfqwtdgn-ruv8nxiqyta1aoy

comment:5 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawm-dibaa_pzfqwtdgn-ruv8nxiqyta1aoy

  • Resolution set to fixed
  • Status changed from new to closed

with svn-3291 maps can be loaded. maps can be panned, but software still crahses after trying to show searched location on map...

Note: See TracTickets for help on using tickets.