Opened 10 years ago

Closed 10 years ago

#578 closed defect/bug (invalid)

Navit does not recognize larger bin files on android

Reported by: www.google.com/accounts/o8/id?id=aitoawlqblcgamwotrrv6lcj0zouv7zolwq7ulg Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

I followed the Navit on Android page and installed Navit to my HTC Magic. From the planet extractor I selected Germany and downloaded the file. I renamed it as navitmap.bin and put it on the SD card. Navit did not load the map. I looked in settings-->map and there was no binfile listed. Then I just selected the area around my town. The binfile was about 30mb. I put it as navitmap.bin on the sdcard and navit recognized it without problems. I did not figure out the maximum size that works yet and I'm not sure yet if that could help at all. Any ideas what the problem is?

Change History (7)

comment:1 Changed 10 years ago by me.yahoo.com/e_fred1#3eed8

Same issue on Windows Mobile: when there are to large maps (p.e. germany.bin), NavIT crashes on routing. With smaller maps (p.e. switzerland.bin) there are no problems for routing (HTC Artemis, HTC Touch Diamond, HTC Touch Diamond II). thread about this issue in the german forum: http://forum.openstreetmap.org/viewtopic.php?pid=79312#p79312 and following posts.

comment:2 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawlqblcgamwotrrv6lcj0zouv7zolwq7ulg

Are you sure this might be the same problem? Navit does not crash at all. It simply does not recognize the bigger binfiles.

comment:3 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawlqblcgamwotrrv6lcj0zouv7zolwq7ulg

Well, it seemed to be a writing issue to the SD Card. I tried from another machine and it worked from there. Though navit now crashes. But I think there's already a bug report for this.

comment:4 Changed 10 years ago by me.yahoo.com/e_fred1#3eed8

oups.. sorry... my misstake. Of course, its not the same problem. Sorry.

comment:5 Changed 10 years ago by kazer

To the reporter (damn unreadable openID logins :) ) : so, can we consider your issue as solved?

comment:6 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawlqblcgamwotrrv6lcj0zouv7zolwq7ulg

Yes this issue was caused by myself. It's not related to navit.

comment:7 Changed 10 years ago by kazer

  • Resolution set to invalid
  • Status changed from new to closed

Ok fine.

Note: See TracTickets for help on using tickets.