Opened 10 years ago

Closed 10 years ago

#579 closed defect/bug (duplicate)

Routing in the UK

Reported by: www.google.com/accounts/o8/id?id=aitoawke3ydqlxkrjxetvkpfmrt3bhza4xqucwc Owned by: KaZeR
Priority: critical Milestone:
Component: core Version: git master
Severity: Keywords:
Cc: fred@…

Description

When I try to create a long route in the UK, navit systematically fails (just pick any far apart current position/destination pair). "Long" seems to be around 100km, although varies around that figure. When it fails, I get:

navit:route_path_new:no route found, pos blocked

Interestingly enough, this does not happen in France (I don't think it ever failed to give me a route in France).

I know this has been reported before, but this to me is quite important as it basically makes navit not usable in the UK.

Please do something about it!

Change History (7)

comment:1 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawke3ydqlxkrjxetvkpfmrt3bhza4xqucwc

I actually played some more with a specific position/destination trying to go from the position to the destination in incremental steps (changing my destination away from the position to my actual destination) and that fails eventually. However I also tried from the destination, setting my position incrementally away from it towards my actual position and that worked...

comment:2 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawmkw7qh8zqo5rtszg0qlehp5t_zvpfgz3m

I can confirm the same issue in Serbia Start: 44 45' 53 N 20 29' 26 E End: 42 45' 3 N 22 4' 31 E The distance is longer than 100 km. And also if I get it shorter by few hundred meters, it works again. I've checked the openstreetmap data with osm on that particular spot, and there are no duplicate roads.

comment:3 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawmkw7qh8zqo5rtszg0qlehp5t_zvpfgz3m

So far I've confirmed the issue with both navit built from trunk on nokia n810 and PC. It seems that the error message is emitted at route.c:2051

comment:4 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawlci5i5uqkznw_cjantgif-nkdhp-w3qsg

Hello,

this problem is worked around by Kapiteined's patch that can be accessed from the comments of Ticket #456. I had the same problem and this workaround fixed this problem for me. Here is the patch: http://trac.navit-project.org/attachment/ticket/456/route.c.diff

comment:5 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawmkw7qh8zqo5rtszg0qlehp5t_zvpfgz3m

I've tried the patch from #456, and it worked for me as well, except the performance of the routing was badly affected. On Dual Core MacBook? 6.1 it takes 1-3 seconds to calculate route. Nevertheless this looks like a duplicate from #456, so I would suggest that someone with enough privileges to mark this as a duplicate.

comment:6 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawke3ydqlxkrjxetvkpfmrt3bhza4xqucwc

I know it's a duplicate of #456, I have commented on this one. However, since nothing was done, I created a new one to try to stir things a bit!

comment:7 Changed 10 years ago by kazer

  • Resolution set to duplicate
  • Status changed from new to closed

I will tag it as duplicate then. And, for the records, it's better to post a comment on an existing ticket rather than opening a new one. A new one will only clutter the tickets, and make unnecessary noise.

I know it's bad that some tickets are opened for such a long time, but there is so much to do that it's sometimes quite hard to dig specific cases. Anyway, patches (like Ed's one) are welcome, even if it that case it's more a workaround than a patch (which is why the proposed solution isn't committed).

Note: See TracTickets for help on using tickets.