Opened 10 years ago

Closed 9 years ago

#599 closed enhancement/feature request (fixed)

Please raise ulimit in xpm/navit_svg2png

Reported by: tegzed Owned by: KaZeR
Priority: minor Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description (last modified by kazer)

Hello,

I found that conversion from svg to png failed for several icons during the build pocess. It turned out that this was caused by a very strict ulimit setting in xpm/navit_svg2png . In line 22 the maximum allowed cpu time is set to 5 seconds for the conversions:

22         ulimit -t 5

Please raise it to a more reasonable value to enable proper builds on slower machines also.

Thanks, David Tegze

Change History (2)

comment:1 Changed 10 years ago by kazer

  • Description modified (diff)

comment:2 Changed 9 years ago by kazer

  • Resolution set to fixed
  • Status changed from new to closed

Limit has been raised to 10s in r3661. We can't put a too high value, because the svg converters do have bugs which will let them run in an endless loop.

Note: See TracTickets for help on using tickets.