Opened 7 years ago

Closed 4 years ago

#603 closed enhancement/feature request (Incomplete/Missing infos)

GPS augmentation in Navit

Reported by: mvglasow (2) Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

This ticket is a result of splitting #567 into one ticket per issue.

Some time ago I passed through the area at http://www.openstreetmap.org/?lat=45.83935&lon=9.03657&zoom=17&layers=B000FTF (errors in OSM data were fixed afterwards) on the highway, eastbound lane. Shortly before, I had set Navit (build 3134, WinCE) to a destination in Milan, just off the highway.

I was in a tailback in front of the border, thus moving slowly. As I passed the point just east of the border where a local road goes underneath the highway, Navit determined that my position was on that road, just in the middle between the two highway lanes, and instructed me to turn around if possible.

A later analysis of OSM data revealed that neither the highway nor the local road had any layer/tunnel/bridge information, thus making it look almost like a level crossing - except for the fact that the ways do not have any points in common.

One key ingredient to the problem was certainly the erroneous OSM data (which has now been fixed at this spot); possible ways to deal with bad data will be discussed in a separate ticket.

The other source of problems is the apparent lack of GPS augmentation in Navit: The GPS signal is somewhat crude by design and may be a few meters off (the error is expressed by the DOP values, and even a low DOP does not guarantee an accurate reading as errors due to reflectors might go unnoticed).

A first approach to coping with that is "snap to roads". This mechanism reaches its limits when multiple roads are in "range". Here, we will need some more information. In the present case it might have helped to consider history information: if prior readings made it somewhat certain that the vehicle was following one particular road, then only those roads that can be reached from there are eligible for the "snap to roads" feature. That is: if the vehicle is traveling towards a bridge, it is highly unlikely that in the next moment it is following the road going underneath that bridge - it is almost certainly crossing the bridge.

Admittedly, GPS augmentation is a huge chapter and one could write a paper or even a book on this - I have been collecting a few ideas for some time, which I am planning to make available, so that we can discuss what makes sense to implement in Navit.

Change History (4)

comment:1 Changed 7 years ago by mvglasow (2)

See also #604 for dealing with bad OSM data.

comment:2 Changed 7 years ago by tiiiim

I'm adding no great value here, but this is just a comment to say that THIS IS A MAJOR PROBLEM FOR ME when using Navit!! So if you can get this fixed, I'd be so, so happy!!

comment:3 Changed 6 years ago by mvglasow (2)

Approaches so far (no changes committed so SVN so far):

  • #799: maintain last valid bearing if an invalid one is obtained
  • #920: ignore bearing when standing still (use last bearing instead)
  • #901: tunnel extrapolation

comment:4 Changed 4 years ago by usul

  • Resolution set to Incomplete/Missing infos
  • Status changed from new to closed

Can anybody please confirm if this issue needs still improvement?

In general we need to put the focus on the major aspects, as we have currently a very limited dev team. So we rely on GPS only (even a very small number of users/devices might offer augmentation abilities like INS trough sensors). But Navit should always be in a defined state that doesn't confuse the driver.

Note: See TracTickets for help on using tickets.