Opened 10 years ago

Closed 9 years ago

#625 closed defect/bug (invalid)

navit-svn-3506 on wince: zoom_out() fails

Reported by: messpert Owned by: number6
Priority: trivial Milestone:
Component: core Version: git master
Severity: Keywords: wince gui zoom out osd
Cc: http://wiki.navit-project.org/index.php/user:messpert, nick@…

Description

Upgrading a minimal wince satnav (wince 5.0) to todays svn: http://download.navit-project.org/navit/wince/svn/navit-svn-3506.zip

Tapping on the "-" icon for zoom-out() has no effect.

Here is a navit.log from a session in which I tapped on "+" {zoom_in(), which worked} and then on "-" {which didn't work}. I did this three times: The log only records the 'zoom_in()' calls.


{{{ Navit log started

navit:file_wordexp_new:wordexp('\SDMMC\navit\data/bookmark.txt') returned 1

vehicle_wince:vehicle_wince_new:on_eof=0[[BR]]

navit:file_wordexp_new:wordexp('track_%Y%m%d-%%i.gpx') returned 1

vehicle_wince:wince_port_reader_thread:GPS Port:[com7:]

vehicle_wince:vehicle_wince_parse:no leading $ in '6,254,27,29,35,193,30*78'

speech_espeak:espeak_new:path_home set to \SDMMC\navit/espeak-data

speech_espeak:espeak_new:Testing \SDMMC\navit/espeak-data/voices/en-us and \SDMMC\navit/espeak-data/voices/en/en-us

speech_espeak:espeak_new:Language full en-us lang en result en-us

graphics_win32:create_memory_dc:resize memDC to: 320 240

graphics_win32:create_memory_dc:resize memDC to: 320 240

graphics_win32:WndProc:resize gfx to: 320 240

navit:file_wordexp_new:wordexp('\SDMMC\navit\data/destination.txt') returned 1

graphics_win32:create_memory_dc:resize memDC to: 26 26

graphics_win32:create_memory_dc:resize memDC to: 70 70
navit:main_real:Using '\SDMMC\navit/navit.xml'

graphics_win32:event_win32_main_loop_run:enter[[BR]]

navit:osd_std_click:calling command 'zoom_in()'

navit:osd_std_click:calling command 'zoom_in()'

navit:osd_std_click:calling command 'zoom_in()'

gui_internal:gui_internal_set_refresh_callback:cond=(null)[[BR]]

gui_internal:gui_internal_set_refresh_callback:cond=(null)[[BR]]

graphics_win32:event_win32_main_loop_quit:enter[[BR]]

navit:debug_dump_mallocs:mallocs 0 }}}


This is, of course, a show stopper, hence major priority.

On this minimal wince, I have no access to any debugging tools, so can't be of much help. On my first attempt, navit crashed with an uncaught exception, but I wasn't able to reproduce that.

navit.xml attached: the version in the svn-nnn.zip files needs extensive editing before it can be used. (center modified to protect location).

Attachments (2)

navit.xml (192.7 KB) - added by messpert 10 years ago.
navit.xml used on wince
navit.log (3.3 KB) - added by messpert 10 years ago.
navit.log from navit-svn-3507.zip

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by messpert

navit.xml used on wince

comment:1 Changed 10 years ago by messpert

Same problem with navit-svn-3507. Not a surprise, I suppose, since I cannot see anything checked into svn to address the problem. The last version that I used successfully on this hardware was svn-3495, but I didn't try the intermediate versions, so it doesn't help much to narrow things down. Can't try those other versions easily since map format has changed?

comment:2 Changed 10 years ago by messpert

Further testing with navit-svn-3507 gives a more confused picture :-) Sometimes *after dragging the map*, the zoom_out() command is called, but also moves the map back to the gps-point (in follow mode). Normally zoom-out() is still not called. So it looks like some side effect of dragging the maps somehow enables the zoom-out() call, which then has other unexpected side effects. :-) Looks as if this will not be easy to track down. Attaching a navit.log from such a svn-3507 run.

Changed 10 years ago by messpert

navit.log from navit-svn-3507.zip

comment:3 Changed 10 years ago by messpert

  • Cc http://wiki.navit-project.org/index.php/user:messpert added
  • Keywords wince added

Just tested navit-svn-3539.svn (24-Aug-2010) and problem persists.

Is no one else using a wince sat nav? navit on wince seems to have been broken for over a month now... Smells like a concurrency problem?

comment:4 Changed 10 years ago by number6

Messpert,

Your navit.xml file is at fault - not the WinCE port.

Please disable the following line <osd enabled="yes" type="navigation_next_turn"/> by changing it to <osd enabled="no" type="navigation_next_turn"/> This will allow you zoom out. The Next Turn box is on a layer higher then the zoom out button and is preventing it from being pressed.

Please disable the line and report back.

comment:5 Changed 9 years ago by number6

  • Owner changed from KaZeR to number6
  • Status changed from new to assigned

comment:6 Changed 9 years ago by number6

  • Cc nick@… added
  • Keywords gui zoom out osd added

Messpert,

Did doing the above resolve the issue?

N

comment:7 Changed 9 years ago by messpert

  • Priority changed from major to trivial
  • Resolution set to invalid
  • Status changed from assigned to closed

Sorry not to reply or report. I had no notification so have only just seen the comments. I will check my wiki configuration after replying.

Yes, I had come to the same conclusion & apologise for the noise. The osd settings are documented but it is all too easy just to switch "no"->"yes" and forget the need to specify sensible coordinates. When I first came to navit, I saw that & experimented successfully. Just forgot after a couples of months usage.

So this is a non-bug & I will close.

Note: See TracTickets for help on using tickets.