Opened 10 years ago

Closed 9 years ago

#633 closed defect/bug (worksforme)

Routing broken in SVN r3504

Reported by: nioui Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords: routing waypoint
Cc: http://wiki.navit-project.org/index.php/user:rdorsch, http://wiki.navit-project.org/index.php/user:nioui

Description

Routing seems to be broken in SVN, following the waypoint support commits.

At least the demo vehicle is definitely broken, and I think that GPS routing is also broken, but I can't confirm right now whether it's the same issue.

Steps to reproduce: after entering a starting point and a destination, the demo vehicle just stops, or oscillates between a few nearby positions. Also, changing the current position doesn't have any effect. It seems that the route is not updated correctly, and since the demo vehicle gets its position from the route, it's stuck.

This behaviour was introduced in commit 3504, and it seems to come from the block at line 3273 to 3277 in navit/route.c (in function rm_get_item):

	if (!mr->seg && mr->path) {
		mr->path=mr->path->next;
		if (mr->path)
			mr->seg=mr->path->path;
	}

This block was added in commit 3504, and removing it restores the correct behavior of the demo vehicle. However, I didn't manage to track exactly was it is supposed to do, so I don't know what would be the correct fix for this (is this part needed for waypoint support?).

Change History (3)

comment:1 Changed 10 years ago by rdorsch

  • Cc http://wiki.navit-project.org/index.php/user:rdorsch added

comment:2 Changed 10 years ago by nioui

  • Cc http://wiki.navit-project.org/index.php/user:nioui added

comment:3 Changed 9 years ago by kazer

  • Resolution set to worksforme
  • Status changed from new to closed

I just tried, using stock svn code and samplemap from Munchen: it worked. I'm closing the bug, if it occurs again please give more informations about your map.

Note: See TracTickets for help on using tickets.