Opened 7 years ago

Closed 4 years ago

Last modified 3 years ago

#658 closed enhancement/feature request (Incomplete/Missing infos)

Adjustable AutoZoom

Reported by: jwernerny -2- Owned by: number6
Priority: major Milestone: version 0.2.1
Component: core Version: git master
Severity: normal Keywords: osd gui zoom map
Cc: nick@…

Description

When driving local roads, one may want to see 60 seconds ahead. When driving expressways (or rather, when driving long distances), one may want to see 5, 10, 20 or more _minutes_ ahead. The current autozoom does forces one to edit navit.xml to change this, which means it is impractical for real world use.

The attached patch allows the user to adjust the amount of time kept on the screen by using the zoom out and zoom in buttons.

Attachments (1)

autozoom_nice.diff (3.3 KB) - added by jwernerny -2- 7 years ago.
Patch to navit.c to make autozoom usable.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by jwernerny -2-

Patch to navit.c to make autozoom usable.

comment:1 Changed 7 years ago by tegzed

I like the idea. I have applied the patch and made a test drive. I think it's useful to have both user control and automatism to determine zoom level.

comment:2 Changed 7 years ago by number6

  • Cc nick@… added
  • Keywords osd gui zoom map added
  • Owner changed from KaZeR to number6
  • Priority changed from critical to major
  • Status changed from new to assigned

Jwernerny,

I'll test this patch over the coming days.

Nick

comment:3 Changed 7 years ago by tegzed

One small notice about the patch. when enabling this adjustable autozoom the drag timeout mechanism disappears. This is the behavior that remembers if the map was dragged by mouse for some specified time and for that time period incoming vehicle updates will not reposition the map. This enables the user to search for some place on the map while the gps is active. Apart from that I think this makes autozoom more usable.

David

comment:4 Changed 7 years ago by jwernerny -2-

when enabling this adjustable autozoom the drag timeout mechanism disappears.

I think it only disappears if either zoom in or out is triggered. That's probably caused by the call to "navit_cmd_set_center_cursor(this_)" on lines ~618 and ~653. I put these in to force the update of the display because I was finding I was accidentally zooming all the way in or all the way out too easily before anything appeared to change.

I see 2 possible fixes to that (which I am not sure I am going to get a chance to look at soon):

  1. Put some logic around the call looking for the timeout.
  • John
  1. Use a different function to force the redraw.

comment:5 Changed 7 years ago by jwernerny -2-

I shouldn't think too much.... I have third option for above:

  1. create a module local variable that tracks the number of times zoom-in and -out have been called since last screen update. If the more than X (say 2) have happened, the zoom-in/-out is ignored until the screen is updated.
  • John

comment:6 Changed 7 years ago by kazer

  • Milestone set to version 0.2.0

comment:7 Changed 4 years ago by usul

  • Resolution set to Incomplete/Missing infos
  • Status changed from assigned to closed

There is currently a autozoom_active,autozoom_secs options within the <navit ...> element. Does it already take the road class into account or was the patch dropped?

I send this ticket to pending, till anybody can tell further details.

comment:8 Changed 3 years ago by tylla

  • Severity set to normal

Any update on this?

Note: See TracTickets for help on using tickets.