Opened 10 years ago

Closed 7 years ago

#659 closed defect/bug (fixed)

Fails to receive GPS data through maemo5 interface on Nokia N900

Reported by: sdiconov Owned by: chollya
Priority: major Milestone: version 0.5.1
Component: port/maemo Version: git master
Severity: Keywords: Nokia, N900, maemo, gps
Cc:

Description (last modified by kazer)

Navit has a driver to read GPS data through "maemo" interface on Nokia N900. However, I found that either it does not work or the navit docs are wrong/incomplete.

Background facts:

  • I have a new Nokia N900 with the latest Nokia official firmware 10.2010.19-1 (PR1.2).
  • I am trying to use navit SVN build 3541 (the latest build for N900 I managed to find) and gtk GUI. I downloaded it from http://www.chollya.org/navit and it was reported to work well.
  • The built in GPS of my N900 works. It received sufficient signal during the test because several other GPS apps (ovi maps, maemo mapper, gpsjini) were able to get an instant fix at the same time when I tried to run navit. All apps _except navit_ showed correct coordinates.
  • The navit installation and configs appear to be correct (except for the <vehicle> tag). No XML error messages appear in the console. I downloaded an OSM map of Moscow through extractor, configured it, and it was shown in the navit window, when I tried to find my home address.

Problem: Navit fails to receive coordinates from GPS. There are two configuration examples for the maemo GPS driver. I tried both with different results.

 <vehicle name="my n900" source="maemo://any" retry_interval="1"/>

Navit starts up well and seems stable. The gps icon appears in the status bar indicating that GPS works. But (!) Navit always shows dummy coordinates 0.0000 N 0.0000 E in its own status bar. No messages relating to gps device appear in the console.

  • Second, I found a sample navit.xml from a user, who claimed that it worked for him on a N900. The vehicle tag looks different there:
	<vehicle name="Local GPS" profilename="car" enabled="yes" active="1" source="maemo">
		<!-- Navit can write a tracklog in several formats (gpx, nmea or textfile): -->
		<log enabled="no" type="gpx" attr_types="position_time_iso8601,position_direction,position_speed,profilename,position_radius" data="track_%Y%m%d-%%i.gpx" flush_size="1000" flush_time="30"/>
	</vehicle>

This fails with an error message: navit:tracking_update:failed to get position data 1 1 1 0

This message repeats several times and then navit crashes. I must note that this sample XML was made for an older build of navit because it uses some deprecated tags. I also tried to combine both examples, add "refresh" and "follow" attributes, but nothing different happened.

Is it a known problem? Can it be caused by the general N900 firmware update? Can it be that the nokia gps works in "binary" mode, while navit wants NMEA text stream or the opposite?

Please, help me to make the correct <vehicle> tag for N900.

Change History (4)

comment:1 Changed 10 years ago by kazer

  • Component changed from core to port/maemo
  • Description modified (diff)
  • Owner changed from KaZeR to chollya

From your first vehicle, it doesn't seem to be enabled. Have you tried to enable it?

comment:2 Changed 9 years ago by akashihi

First of all - could you upgrade to 4559? Please also check, that you have only one configured/enabled vehicle.

comment:3 Changed 7 years ago by usul

  • Milestone set to version 0.5.1

If somebody can provide me a uptodate SVN maemo build, I can check if this is still an issue

comment:4 Changed 7 years ago by usul

  • Resolution set to fixed
  • Status changed from new to closed

The bokomoko svn5560 navit runs fine on the most current maemo5 community package (CSSU 21.2011.38-1) on a N900. I updated the installguide at http://wiki.navit-project.org/index.php/Maemo

Note: See TracTickets for help on using tickets.