Opened 8 years ago

Closed 8 years ago

#668 closed enhancement/feature request (duplicate)

wince only small maps sizes possible

Reported by: killerhippy Owned by: number6
Priority: major Milestone:
Component: port/wince Version: git master
Severity: Keywords:
Cc: nick@…

Description

I can use openstreet maps for my city with filesizes about 30 MB, larger maps are not usuable, navit aborts, so I cannot use maps for my country or the like. I am pretty shure that this has to do with the limits of the small device I have:

Asys Mypal A636N has 64 MB RAM

Is there planning about using big maps on low memory devices?

A commercial navigation software I know has maps far bigger than the device's memory, so there is ways to do that.

I would be happy to use bigger maps on my device.

Change History (7)

comment:1 follow-up: Changed 8 years ago by number6

  • Cc nick@… added
  • Owner set to number6
  • Status changed from new to assigned

Hi Killerhippy,

I'm running a WinCE device with 64MB of RAM and I'm able to take in large enough map files (circa 1GB).

Can you delete all the data in navit.log, start it up with a small map file (that is, a base system) and then a map larger than your 30MB limit so we can have a look?

Also, where are you getting the mapfile from?

Number6

comment:2 in reply to: ↑ 1 Changed 8 years ago by jrahe

Replying to http://wiki.navit-project.org/index.php/user:number6:

Hi Killerhippy,

I'm running a WinCE device with 64MB of RAM and I'm able to take in large enough map files (circa 1GB).

Can you delete all the data in navit.log, start it up with a small map file (that is, a base system) and then a map larger than your 30MB limit so we can have a look?

Also, where are you getting the mapfile from?

Number6



Hello number6, ...I´ve got a similar problem with my device. I have a Palm Treo 750 with Windows Mobile 6 Prof. This device only has about 64 MB RAM. After a softreset there are only about 24 MB RAM free. Thats the maximum after optimisation. Starting navit there are only 17,8 MB RAM free. So far, so good. Starting a navigation for a too long distance, navit abort for itself.

=> this is no question of the size of maps (they could be more than 1 GB, stored on a MicroSD-Card, that´s no problem)

=> this is a question of how many details and points navit used for calculating the navigation. These details all are resident in the RAM.

Example 1: I can navigate to Skagerak (Denmark) with a distance of about 500 km, because there are not so much details.

Example 2: I can´t navigate downtown Hamburg with a distance of only 50 km, because there are too much details = too much RAM neede => navit will abort itself.

========
So, no question of mapsize, but a question of distance and number of details while navigating (...and a question of memory-handling from navit) ========

comment:3 Changed 8 years ago by number6

This is a common problem, due to routing.

Since there are not a lot of roads between two locations, you can route long distances compared to, say, a city with lots of roads.

You will need to do a cross compile of Navit, for WinCE / Windows mobile (I have the exact same phone, so I can confirm that it works).

To do a cross compile, take a look at http://nickgeoghegan.net/navit/navit-cross-compile and http://wiki.navit-project.org/index.php/Compiling_Navit_for_WinCE/WinMobile

You'll then edit route.c

Replace line 960 - sel->next=route_rect(8, &c[i], &c[i], 0, 40000); with sel->next=route_rect(8, &c[i], &c[i], 0, 80000);

Replace line 962 sel->next=route_rect(18, &c[i], &c[i], 0, 10000); with sel->next=route_rect(18, &c[i], &c[i], 0, 20000);

Compile, and put the navit.exe wherever it needs to go.

On the Treo 750, I've been able to use 40000 with 400000, and 10000 with 100000. Calculating the route, however, is slow.

comment:4 Changed 8 years ago by jrahe

Thanks for this advice !

I have no Linux machine and I´ve never did compiling or something like this. So it seemed to be a little bit too complicated and "time-expansive" for me, to do my own "cross-compiling".

On the other hand it would be great to use navit on my loved Treo 750 in an expanded way. Doing my own compiling I also could reduce the number of POIs navit should use.

BTW: what kind of parameter do you change in your example? Do you expand the distance for the next calculated routing point?

Thanks and greetings Jörg

comment:5 Changed 8 years ago by number6

Jörg,

The values changed are for the rectangle that Navit uses for routing.

With the numbers so large, I've been able to compute a route from Galway, Ireland to Hannover, Germany. It does take a very long time to compute, though, and I've not tried to route that far on the Treo.

A cross compile isn't that hard, if you get Ubuntu and install it with Wubi, you can easily cross compile (just be sure to take care of dependencies).

Might look at doubling the routing numbers, and see how people find it. It would be great if you could double the routing numbers and let me know - more testers the better!

Nick

comment:6 Changed 8 years ago by jrahe

Nick, ...what are the "routing numbers"?

Are you talking about the values mentioned above: 10000 -> 20000 40000 -> 80000

If I get a little bit time this weekend, I´ll give it a try.

Whats the best way to contact you for questions about compiling? Is it this "thread"? Or do you have an e-mail account for PM?

So long, greetings Jörg

comment:7 Changed 8 years ago by number6

  • Resolution set to duplicate
  • Status changed from assigned to closed

Jörg,

I'm on IRC - #navit on irc.freenode.net / http://webchat.freenode.net/?channels=navit - as number6.

The numbers relate to a rectangle (in the map), and the number of items in this rectangle (roads).

Basically, increasing the numbers just allows for more places to be checked and will help you route long distances. This issue is noted in #456

I'm going to close this ticket, as it's a duplicate of #456.

If you need me, Jörg, I'm on IRC :)

Note: See TracTickets for help on using tickets.