Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#703 closed defect/bug (fixed)

osd_configuration doesnt work properly

Reported by: mineque Owned by: Singesang
Priority: critical Milestone: version 0.2.1
Component: osd/core Version: git master
Severity: Keywords: osd osd_configuration
Cc:

Description

First of all; if we change actual osd_configure from "1" to "2" and there is on "1" item odometer (when you know where to hit, because you dont see it) you can stop it.

Secondly it have to be implemented starting osd configuration because now it loads all osd items which isnt good way.

After few changes of visible items there is problem with changing them and even entering menu because unvisible item block click on the map.

Change History (3)

comment:1 Changed 10 years ago by tegzed

Hi Mineque,

Thanks for spotting the problem. You are absolutely right, the bug is in the odometer(and stopwatch) click handler. Will commit the fix soon.

comment:2 Changed 10 years ago by mineque

  • Resolution set to fixed
  • Status changed from new to closed

solved by adding in navit.xml inside <navit .... > tag parameter osd_configuration="x" > which define default osd configuration.

thanks to Dandor

comment:3 Changed 10 years ago by tegzed

There were also problems with opengl and sdl driver enabled state handling which is solved now. Also the click handler of odometer and stopwatch is fixed. So ticket can be closed.

Note: See TracTickets for help on using tickets.