Opened 9 years ago

Closed 8 years ago

#706 closed defect/bug (duplicate)

OSM area amenities don't get POI or icon in navit

Reported by: mazikeen Owned by: cp15
Priority: minor Milestone:
Component: mapdrivers/OSM Version: git master
Severity: Keywords: poi, area, amenity
Cc:

Description

As OSM becomes more detailed many entities that used to be represented with points are changing to areas. Since the osm importer only generates POIs for points with the specified attribute (eg. amenity=pub) the result is that pubs, restaurants, shops and fuel stations (among others) with area representations are no longer getting an icon in navit, or showing up in the POI lists.

From a user's point of view it doesn't matter whether the carpark, pub or whatever is represented as a point or an area; they just want to be able to find it, use it as a destination or whatever. Mapnik displays an icon at the point, or in the middle of the area. Navit should do likewise. This probably involves the importer creating a POI in the middle of the area if it has an attribute that would normally be used for a POI.

On IRC cp15 said this could cause frustration with users being routed to a side of a building with no entrance, and no easy way round. I believe that's better than not being able to find the building in the first place. Korrosa pointed out the building=entrance attribute which might help, although it isn't widely used. It can't indicate the main entrance if there is more than one, but access=private may indicate a staff-only entrance.

IRC log of some discussion on this subject: http://www.hentges.net/irclogs/%23navit/2010/December/20101218_navit.log

OSM wiki for building entrances: http://wiki.openstreetmap.org/wiki/Tag:building%3Dentrance

Change History (3)

comment:1 Changed 9 years ago by sanderd17

qbout the entrances: the convention is that they have to be used for big buildings (those of which you have to walk a while to find the entrance otherwise). I guess that's a good convention.

Sometimes the entrances have an own name or ref. e.g.: http://www.openstreetmap.org/browse/node/1037539139 http://www.openstreetmap.org/browse/node/1037539164 http://www.openstreetmap.org/browse/node/1037539172

So I think it would be best to combine the names of the building and the entrance in one POI (if that's possible). Something like "VDC - Winkel" for the last link. Or in genaral "Building name - entrance name".

If there is no entrance node, than the building "should" be small (or OSM information isn't complete and that's not a Navit problem) and thus a random place for the node inside the building can be made, or a node of the building outline can be used as POI.

This problem is quite important. Since the availability of Bing imagery, the community has started with drawing buildings and moving the tags to the buildings outlines.

So if Navit doesn't support tags on buildings, a lot of info will get lost.

comment:2 Changed 9 years ago by ziaou

  • Keywords poi area amenity added

In France, many buildings are automatically imported from the "Cadastre" and most of new POI are affected to an area instead of a point, because the building now exists.

comment:3 Changed 8 years ago by arnaud le meur

  • Resolution set to duplicate
  • Status changed from new to closed

Same problem with area shops.

Duplicate of #477

Note: See TracTickets for help on using tickets.