Opened 8 years ago

Last modified 4 years ago

#710 reopened enhancement/feature request

screen rotation: some osd types do not work with negative positions

Reported by: dirk205 Owned by: cp15
Priority: minor Milestone: version 0.5.1
Component: osd/core Version: git master
Severity: normal Keywords: osd text WVGA display
Cc: http://wiki.navit-project.org/index.php/user:mvglasow, (2)

Description (last modified by usul)

When creating own skins, you can give negative x/y positions for counting from the bottom or the right:

<osd enabled="yes" type="button"  x="0" y="-85" w="800" h="85" command=""  src="skins/Dirk1/bottom.png" />

This does not work for type="text":

<osd enabled="yes" type="text"  label="ETA: ${navigation.item.destination_time[arrival]}" ...

It becomes a problem when one user prefers landscape mode while other prefer upright --> nothing is displayed for negative y!

Change History (9)

comment:1 Changed 8 years ago by mineque

could you give full osd item code? because first you write about button then text. i didnt noticed problems with negative value.

comment:2 Changed 8 years ago by korrosa

  • Resolution set to worksforme
  • Status changed from new to closed

This works absolutely fine for me. I'm closing as worksforme - please re-open if you have new information.

Please provide details of:

  • Navit version and download source
  • Platform and OS
  • Use-case example - provide the full line of code which doesn't work for you.

comment:3 Changed 8 years ago by dirk205

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hi,

ok, more information:

  • I downloaded navit by official svn and have version 0.5.0.3810 from Dec 21st now. My compiler is arm-mingw32ce-gcc (GCC) 4.4.0 with recent cygwin on WinXP.
  • My device 1 is an HTC HD2 running Windows Mobile 6.5 with 800x480 display. Navit always starts up in portrait mode and I rotate the device horizontally to switch to landscape view.
  • My device 2 is a FSC N520 running Windows Mobile 5.0 with 320x240 display. I can start Navit both in landscape or portrait mode and can rotate by a special button.

This piece of code shows the problem on my devices: <osd enabled="yes" type="gps_status" x="-50" y="0" w="50" h="30" align="0" background_color="#00000000" font_size="150" />

Problem: (At first, it works.) Then, if you rotate the screen while running navit, both devices will no longer display objects of type text, gps_status, and navigation_next_turn. Even re-rotating will not show them again. But type="button" always works fine. --> Using only non-negative numbers you cannot create skins which work both for landscape and portrait mode.

Anyway, this is a minor problem because most user use one screen mode only. ;-)

comment:4 Changed 8 years ago by mineque

ok, so that is not a bug it's feature ;)

and seriously, navit doesnt support autorotation and EOT. maybe someday. Now it doesnt support rotation and scalling os items. and there is no swapping mechanism for changing between two skins.

When you read please close ticket

comment:5 Changed 8 years ago by dirk205

  • Summary changed from skin creation: some types do not work with negative positions to screen rotation: some osd types do not work with negative positions
  • Type changed from defect/bug to enhancement/feature request

Changed into "screen rotation" feature request, ok? Navit does not seem far away from proper handling, many things already work.

comment:6 Changed 8 years ago by mineque

  • Component changed from gui/internal to osd/core

sure but dont expect it soon.

main problem we could describe as: handling xml file live swap. problem is known but i'll create ticket for it.

comment:7 Changed 5 years ago by usul

  • Description modified (diff)
  • Keywords display added
  • Milestone set to version 0.5.1

Was this bug fixed on all platforms already? As releated to stability/reproduce results, I schedule for 0.5.1

comment:8 Changed 4 years ago by mvglasow (2)

  • Cc http://wiki.navit-project.org/index.php/user:mvglasow (2) added
  • Severity set to normal

comment:9 Changed 4 years ago by mvglasow (2)

I recently fixed a lot of stuff regarding scaling/resizing of OSD items (#983, #1059, #1260, #1261, #1262, #1267). I have tested this with a bunch of OSD items including negative x/y coordinates as well as relative widths.

At least on Android and Linux, these things should work now. I haven't tested this on Windows CE – can you (or anyone else) confirm whether or not it it still an issue?

Note: See TracTickets for help on using tickets.