Opened 6 years ago

Closed 4 years ago

#716 closed defect/bug (fixed)

"Set as position" is not functioning correctly, and cannot route with demo vehicle (arm-mingw32ce-gcc (GCC) 4.4.0 with recent cygwin on WinXP)

Reported by: dirk205 Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

a) The new position is not shown in the menu nor cursor on map. b) A route to a destination cannot be made.

Attachments (2)

osm_germany2.jpg (127.1 KB) - added by dirk205 6 years ago.
first map (active)
osm_mexico.png (136.0 KB) - added by dirk205 6 years ago.
second map (active)

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by mineque

if you want to make a trial route please enable demo vehicle and in the menu change to demo car. how do you want to calculate route when navit doesnt know where you are?

comment:2 Changed 6 years ago by korrosa

  • Resolution set to invalid
  • Status changed from new to closed

dirk205: Setting a position is used WHEN you have no GPS fix - i.e. it can be used to calculate a route from the position to the destination. To answer the two particular points: a) A cursor is not shown on the map because a cursor is only shown for gps fixes. If you want a cursor to be shown when selecting a position without a GPS fix, update this ticket title and make it clear. b) A route to a destination *can* be made, or at least it works for me. There may be problems with the underlying OSM data, or you may be hitting a well known bug in Navit when calculating routes over 80km long - there's a ticket about that already.

I'm going to close this ticket as it's unclear what the desired outcome is. Feel free to re-open the ticket, but include: a) Platform and OS b) Navit version and source (i.e. where you got it from) c) Use-cases. If routing doesn't work, please say where you tried to from and to. d) What you actually want fixed.

comment:3 follow-up: Changed 6 years ago by dirk205

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from Setting a position w/o GPS fix has no effect to Cannot set a position w/o GPS fix (impossible to do trial routing)

Hi,

ok, more information:

  • I downloaded navit by official svn and have version 0.5.0.3810 from Dec 21st now. My compiler is arm-mingw32ce-gcc (GCC) 4.4.0 with recent cygwin on WinXP.
  • My device 1 is an HTC HD2 running Windows Mobile 6.5 with 800x480 display.

if you want to make a trial route please enable demo vehicle and in the menu change to demo car.

Yes, this is my intention = use case. Now, I changed to "demo car" via menu after activating

<vehicle name="Demo" profilename="car" enabled="yes" active="no" source="demo://"/>

but I still cannot set the current position from card nor bookmark. Without the position I cannot route, that's clear to me.

comment:4 in reply to: ↑ 3 Changed 6 years ago by mineque

Replying to http://wiki.navit-project.org/index.php/user:dirk205:

if you want to make a trial route please enable demo vehicle and in the menu change to demo car.

Yes, this is my intention = use case. Now, I changed to "demo car" via menu after activating

<vehicle name="Demo" profilename="car" enabled="yes" active="no" source="demo://"/>

look at bolder, apart from enabled you have also active parameter.

comment:5 Changed 6 years ago by korrosa

  • Summary changed from Cannot set a position w/o GPS fix (impossible to do trial routing) to "Set as position" is not functioning correctly, and cannot route with demo vehicle (arm-mingw32ce-gcc (GCC) 4.4.0 with recent cygwin on WinXP)

dirk205: Thanks for taking the time to update the ticket. In addition to ensuring that active=yes in navit.xml for the demo vehicle (this just means we're negating any errors in the GUI for now when activating the demo vehicle), can you also please provide the route details. Where are you trying to route from, and where are you trying to route to? Also, where are your maps coming from for these trials?

Changed 6 years ago by dirk205

first map (active)

Changed 6 years ago by dirk205

second map (active)

comment:6 Changed 6 years ago by dirk205

ensuring that active=yes in navit.xml for the demo vehicle

OK, I tried. Same problem.

can you also please provide the route details. Where are you trying to route from

I tip on a street on the map (menu opens), then I try to set as the current position. Another try is to set a bookmark as the position.

where are you trying to route to

To a bookmark or a location on the map.

where are your maps coming from for these trials?

From Navit:Planet Extractor, see screen shots attached. I try in the area of Germany only. German map is from Dec 13th.

comment:7 Changed 6 years ago by dianebadua

but I still cannot set the current position from card nor bookmark. Without the position I cannot route, that's clear to me.

air jordan

comment:8 Changed 4 years ago by usul

  • Resolution set to fixed
  • Status changed from reopened to closed

I can't confirm this behaviour on the current WinCE builds. I tested with different devices during the past days and everything is fine. Please reopen the ticket if it's not obsolet and provide us more informations (what device, official svn build, step by step procedure to reproduce the bug). Anyway, thanks for pointing us to this issue :)

Note: See TracTickets for help on using tickets.