Opened 10 years ago

Closed 3 years ago

#729 closed defect/bug (duplicate)

Missing xpm-files from fresh install

Reported by: foxxi59 Owned by: KaZeR
Priority: critical Milestone: version 0.5.1
Component: core Version: git master
Severity: normal Keywords: xpm icons missing
Cc: jff@…

Description

Under ubuntu 10.10 some icons are not found / missing in svn 3883

Attachments (11)

console-error.txt (43.0 KB) - added by foxxi59 10 years ago.
error messages from console
download_xpm.txt (28.8 KB) - added by foxxi59 10 years ago.
xpm dir after download
autogen_xpm.txt (28.9 KB) - added by foxxi59 10 years ago.
xpm dir after autogen
make_xpm.txt (158.0 KB) - added by foxxi59 10 years ago.
xpm die after make
autogen-sh.txt (3.1 KB) - added by foxxi59 10 years ago.
output from autogen
configure.txt (17.5 KB) - added by foxxi59 10 years ago.
output from configure
make Part1.txt (229.8 KB) - added by foxxi59 10 years ago.
output from make part 1
make Part1a.txt (34.7 KB) - added by foxxi59 10 years ago.
output from make part 1a
make Part2.txt (207.9 KB) - added by foxxi59 10 years ago.
output from make part 2
make Part2a.txt (81.5 KB) - added by foxxi59 10 years ago.
output from make part 2a
navit.xml (185.1 KB) - added by foxxi59 10 years ago.
navit.xml

Download all attachments as: .zip

Change History (19)

Changed 10 years ago by foxxi59

error messages from console

Changed 10 years ago by foxxi59

xpm dir after download

Changed 10 years ago by foxxi59

xpm dir after autogen

Changed 10 years ago by foxxi59

xpm die after make

Changed 10 years ago by foxxi59

output from autogen

Changed 10 years ago by foxxi59

output from configure

Changed 10 years ago by foxxi59

output from make part 1

Changed 10 years ago by foxxi59

output from make part 1a

Changed 10 years ago by foxxi59

output from make part 2

Changed 10 years ago by foxxi59

output from make part 2a

comment:1 Changed 10 years ago by foxxi59

<graphics type="gtk_drawing_area"/> <gui type="gtk" enabled="yes" menubar="1" toolbar="1" statusbar="1"/>

comment:2 Changed 10 years ago by foxxi59

  • Priority changed from major to critical

Changed 10 years ago by foxxi59

navit.xml

comment:3 Changed 10 years ago by foxxi59

  • Summary changed from failed xpm-files to missing xpm-files

comment:4 Changed 10 years ago by korrosa

  • Summary changed from missing xpm-files to Missing xpm-files from fresh install

I've run a script over navit.xml to try and see which icons are defined in the xml file, but missing from the xpm folder.

Notes:

  • The following results were achieved after compiling Navit from svn r3890 on Ubuntu 10.04LTS Lucid Lynx.
  • The block below shows the icons which are defined in navit.xml but missing from the xpm folder.
  • Inkscape is installed on my system. During make, Inkscape was used to create the icons.
    ------------------------------------------
    LAYOUT: Car
    ------------------------------------------
    mini_roundabout
    turning_circle
    town_ghost
    poi_hotel
    poi_cafe
    poi_bridge
    poi_camp_rv
    poi_museum_history
    poi_dining
    poi_auto_club
    poi_bay
    poi_bend
    poi_border_station
    poi_bowling
    poi_business_service
    poi_car_rent
    poi_car_wash
    poi_casino
    poi_communication
    poi_concert
    poi_cove
    poi_crossing
    poi_dam
    poi_danger_sea_wreck
    poi_daymark
    poi_diving
    poi_drinking_water
    poi_emergency
    poi_fair
    poi_fish
    poi_forbidden_area
    poi_shop_gps
    poi_government_building
    poi_height
    poi_hotspring
    poi_icesport
    poi_information
    poi_landmark
    poi_levee
    poi_locale
    poi_loudspeaker
    poi_mall
    poi_manmade_feature
    poi_marine
    poi_marine_type
    poi_mine
    poi_nondangerous
    poi_oil_field
    poi_personal_service
    poi_restricted_area
    poi_sailing
    poi_scenic_area
    poi_school
    poi_service
    poi_shop_apparel
    poi_shop_computer
    poi_shop_department
    poi_shop_furniture
    poi_shop_handg
    poi_shop_merchandise
    poi_shop_retail
    poi_shower
    poi_social_service
    poi_sounding
    poi_stadium
    poi_telephone
    poi_tide
    poi_trail
    poi_truck_stop
    poi_tunnel
    poi_wine
    poi_worship
    poi_wrecker
    
    ------------------------------------------
    LAYOUT: Car-dark
    ------------------------------------------
    mini_roundabout
    turning_circle
    town_ghost
    poi_car_parking
    poi_bridge
    poi_camp_rv
    poi_museum_history
    poi_dining
    poi_auto_club
    poi_autoservice
    poi_bay
    poi_bend
    poi_border_station
    poi_bowling
    poi_business_service
    poi_car_rent
    poi_car_wash
    poi_casino
    poi_communication
    poi_concert
    poi_cove
    poi_crossing
    poi_dam
    poi_danger_sea_wreck
    poi_daymark
    poi_diving
    poi_drinking_water
    poi_emergency
    poi_fair
    poi_fish
    poi_forbidden_area
    poi_shop_gps
    poi_government_building
    poi_height
    poi_hotspring
    poi_icesport
    poi_information
    poi_landmark
    poi_levee
    poi_locale
    poi_loudspeaker
    poi_mall
    poi_manmade_feature
    poi_marine
    poi_marine_type
    poi_mine
    poi_nondangerous
    poi_oil_field
    poi_personal_service
    poi_restaurant
    poi_restricted_area
    poi_sailing
    poi_scenic_area
    poi_school
    poi_service
    poi_shop_apparel
    poi_shop_computer
    poi_shop_department
    poi_shop_furniture
    poi_shop_handg
    poi_shop_merchandise
    poi_shop_retail
    poi_shower
    poi_social_service
    poi_sounding
    poi_stadium
    poi_tide
    poi_trail
    poi_truck_stop
    poi_tunnel
    poi_wine
    poi_worship
    poi_wrecker
    

comment:5 Changed 7 years ago by usul

  • Resolution set to fixed
  • Status changed from new to closed

We currently working on creating a new concept of unified styles and icons, so we will take care, that there are no broken icon references anymore. https://forum.navit-project.org/viewtopic.php?f=19&t=409

For cleanup reasons, I closed this ticket.

comment:6 Changed 7 years ago by sleske

  • Resolution fixed deleted
  • Status changed from closed to reopened

Cleaning up old tickets is a good idea, but only if the problem is actually fixed. So I'm reopening this ticket. The ticket has the keyword "xpm"; if the new concept works, all the "xpm" tickets can probably be closed, including this one.

comment:7 Changed 7 years ago by usul

  • Milestone changed from version 0.5.0 to version 0.5.1

comment:8 Changed 3 years ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Resolution set to duplicate
  • Severity set to normal
  • Status changed from reopened to closed

I will close this ticket because we have the Meta Ticket #221 for that. Also we will add a script on our ci that parses the default navit.xml on every build. So this will be fixed.

Jkoan

Note: See TracTickets for help on using tickets.