Opened 10 years ago

Closed 10 years ago

#734 closed defect/bug (invalid)

no localisation

Reported by: sanderd17 Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc: http://wiki.navit-project.org/index.php/user:sanderd17

Description

When I installed the current navit to my android. I saw that all menus were in English and the voice commands are in English too. It doesn't matter if I set Dutch (nl) or Dutch (be) as my phone languages. Navit stays in English.

When I look at the tools. I see that the lang is

LANG=nl_NL(1=1 2=2)

So Navit detects my language but doesn't seem to translate it.

I remember that it used to be

LANG=nl_NL

I can live with menus in English, but since eSpeak also has to speak English commands, I have to put eSpeak in English which pronounces the streetnames just wrong.

Change History (4)

comment:1 Changed 10 years ago by sanderd17

  • Cc http://wiki.navit-project.org/index.php/user:sanderd17 added

comment:2 Changed 10 years ago by sanderd17

Ok, I discovered something more. The problem isn't between different Navit versions, but between different android versions. On Android 1.6 stock ROM, I can choose to put my phone in Dutch, French, English or German. The navit menu is adapted to the main language I choose.

If I'm in android 2.2, a custom CM6 based ROM, I can choose a lot more languages. Including English (US), English (UK), Dutch (NL), Dutch (BE) ... But Navit stays in English although the "show locale" tool says "NL_be (1=1) (2=2)". Is it possible that Dutch (BE) isn't treated the same way as Dutch?

comment:3 Changed 10 years ago by sanderd17

I don't know what the problem could be. Localisation works with an AVD. So it has to be a combination of the ROM and navit that causes problems.

Does someone uses a Cyanogen Mod 2.2? Do you have the same problem or not?

comment:4 Changed 10 years ago by sanderd17

  • Resolution set to invalid
  • Status changed from new to closed

Sorry for the problems. Uninstalling and reinstalling solved it.

Thanks cp15.

Note: See TracTickets for help on using tickets.