Opened 10 years ago

Closed 9 years ago

#758 closed defect/bug (fixed)

Crash in 3D view

Reported by: perepujal Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

I get reproducible crashes when running at some points of the map.

Attached is a nmea file that passes over one of those points, set it as source of a vehicle and you should be able to reproduce.

Attachments (4)

nmea_20110120.nmea (71.5 KB) - added by perepujal 10 years ago.
btfull (15.4 KB) - added by perepujal 10 years ago.
Full backtrace , svn 2011-feb-03 plus the patch
newcrash1111.nmea (65.7 KB) - added by perepujal 10 years ago.
3d_crash.diff (1.4 KB) - added by tegzed 10 years ago.
another try to fix 3d crash

Download all attachments as: .zip

Change History (15)

Changed 10 years ago by perepujal

comment:1 Changed 10 years ago by momcilo

I can confirm that I have the same issue which constantly occurs at the same location. I will try to generate a log. The same locations are OK when using 2D; so I guess it is related to the 3D drawing engine.

comment:2 Changed 10 years ago by tegzed

Can you provide a stack trace please?

comment:3 Changed 10 years ago by perepujal

I've runned valgrind over navit and it leads me to the draw_mode() function in graphics_sdl.c Seems that in some runnings of it, ov->overlay_x and ov->overlay_y are not initialized, even if the check for if(ov && ov->overlay_enable==TRUE) passes, simply put a printf() there to see what I mean.

Forgot to say that the location of the nmea file is in the Pirinean mountains, so the spanish or french maps should show it.

Also the configuration is setted to gui internal, graphics sdl and lock on road.

comment:4 Changed 10 years ago by tegzed

Hello Perepujal,

I also observed crashes when replayed that nmea file. I fixed some of them in svn rev 4063, however there is still one more crash with this nmea. I have a workaround(see attached 3d_crash.diff) for that but I haven't committed it since I don't understand fully that part of the code and this problem should be viewed by somebody who is more familiar wit that code.

comment:5 Changed 10 years ago by perepujal

Doesn't work for me on my pc, still having crashes :( Tomorrow monday I will take a 12 hours travel and test it in my tomtom in the wild. Pere

comment:6 Changed 10 years ago by tegzed

Hello Pere

Have you applied the attached patch or just use svn? Without applying and compiling it crashes for me too. If it still crashes a stack trace would be usefull. please set <debug name="segv" level="1"/> or <debug name="segv" level="2"/> in your navit.xml and copy the stack trace from your output. if you set the latter one with level="2" you will be dropped to a gdb shell after the crash. Please type "bt full" in that shell and paste the result so I can check the problem in more detail.

Changed 10 years ago by perepujal

Full backtrace , svn 2011-feb-03 plus the patch

comment:7 Changed 10 years ago by perepujal

Hi Tegzed It seems related too to the angle of the view, I run usually with pitch="30" I managed another nmea file that crashes navit at pith 20 after about 85 seconds, but instantly at pitch 30, and after just one second at pitch 35.

Note also that at pitch 35, navit avorts (instead of crashing) with this message: navit:graphics_draw_polyline_as_polygon:graphics.c:1315 assertion failed:npos > 0

Hope this helps -- Pere

Changed 10 years ago by perepujal

Changed 10 years ago by tegzed

another try to fix 3d crash

comment:8 Changed 10 years ago by tegzed

Hi Perepujal,

I attached another patch to fix this crash. For me it fixed both of your attached trips, I could go through on them without problem with pich value of 20 and 30 using the demo vehicle. Please let me know if this patch works on your config also.

Thanks David Tegze

comment:9 Changed 10 years ago by perepujal

Hi David! It works for me :) Tested with pitch 20, 30, 35, 55 and no pitch and no more getting crashes :)

Many, many thanks :) Pere Pujal

comment:10 Changed 10 years ago by tegzed

Committed to svn in rev 4152. Please close ticket if still OK.

comment:11 Changed 9 years ago by perepujal

  • Resolution set to fixed
  • Status changed from new to closed

Done :)

Note: See TracTickets for help on using tickets.