Opened 10 years ago

Closed 10 years ago

#784 closed defect/bug (fixed)

grahic issue in WinCE SVN 4176 Menu

Reported by: jrahe Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords: gui internal POI
Cc: nick@…

Description

I´m using WinCE build SVN 4176 on a Windows Mobile 6.1 device (Palm Treo Pro).

The last build I used was something about SVN 38xx (don´t know the exact number). Up to that build everything works fine. With the update to SVN 4176 I´ve got the following graphic issue:

Going to the menu "bookmarks" and using the D-Pad-Navigation-Key, the first entry will be highlighted. Scolling down, the next entry will be highlighted and the first one will be normal again. This works ok for the first two entries ("add folder" and "add bookmark").
=> But all other entries (bookmarks and folders) will stay highlighted, even if you scroll away from them.

This is irritating, because you can´t see which item is currently selected.

This issue appears also at the menu for POIs.
=> There the highlightning will stay at every icon (for filtering the POIs) and every POI, even if you scroll awayfrom them.

The actual version for navit is SVN 4238, but there is no actual version for WinCE. The most newest one for download is the 4176. http://download.navit-project.org/navit/wince/svn/ Maybe this issue wouldn´t appear in a newer version for WinCE.

Greetings Jörg

Attachments (2)

Screenshot-6.png (81.0 KB) - added by korrosa 10 years ago.
highlight-fix.diff (4.1 KB) - added by tryagain 10 years ago.
Should fix all above issues with highlighting in Bookmarks and POIs.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 10 years ago by jrahe

Just tried the buil #4004 from 25.01.2011 => same graphic issues when scrolling in the bookmarks or POIs.

Greetings Jörg

comment:2 Changed 10 years ago by jrahe

Just tried it with build #4004 on a Treo 750 with Win Mobile 6 Prof. => same issue.

Greetings Jörg

comment:3 Changed 10 years ago by jrahe

Just tried the build #3844 from 02.01.2011 on the Treo 750 => same issue.
I´ll try some more former builds an let you know, which build had been working correctly.

Greetings Jörg

comment:4 Changed 10 years ago by tegzed

I think it is not wince specific, I can reproduce this bug on my linux box also.

comment:5 Changed 10 years ago by jrahe

...ok, I just tried the build #3732 from 29.

11.2010 => NO graphic issue

So it seems, that something changed between November (29.) and December 2010 is causing this issue.

Greetings Jörg

comment:6 Changed 10 years ago by tegzed

Hi jrahe

i guess it is gui internal related, which is the oldest version with the bug present?

comment:7 Changed 10 years ago by korrosa

I can confirm the issue on my Linux install here. Ubuntu 10.04 on netbook, Navit svn r4219, internal gui and gtk_drawing_area graphics. Attached is a pretty screenshot after using the arrow keys to run up and down a couple of times...

Changed 10 years ago by korrosa

comment:8 Changed 10 years ago by jrahe

Hello tegzed, ...the oldest build that I tested with this issue, was build #3844 from 02.01.2011.

The next elder one I tested was the build #3732 from 29.11.2010 with no issue.

Destalling and reinstalling navit on my device tooks about 30 minutes....!! So I only tested a few builds. But the oldest version with the bug present must be sometime in December 2010.

Greetings Jörg

comment:9 Changed 10 years ago by tegzed

Hello Jrahe,

Yesterday I did some tests, I suspect that the problem is the table widget of gui internal which is implemented to make long lists in gui internal scrollable. This is used for bookmarks also. For bookmarks it is definitely the introduction of this widget type that bring this bug in (from #3802 to #3803). I think this widget is implemented by user Tryagain. there is a ticket somewhere with his patch. I have not seen him lately. Maybe he could fix this easily.

comment:10 Changed 10 years ago by jrahe

This would be great.

The ability to scroll in lists like in bookmarks and POIs is very useful, especially on a small display like on my Treo 750 (240x240).

Hope he will/can fix it.

Will you inform him? Or how do I find him resp. his ticket?

Greetings Jörg

comment:11 Changed 10 years ago by tegzed

Unfortunately I don't have any contact info for him, maybe Number6 (alias Geoghegan) can reach him, he committed the patch as I remember.

comment:12 Changed 10 years ago by jrahe

Hello tegzed,

...UPDATE...

In the build #3732 I mentioned before is NO issue when scrolling in the bookmarks. There are also no "small green arrows" for the ability to scroll in the list.

BUT in the same build #3732 there is this graphic issue in the POIs list. And in the POIs there is the ability to scroll in the list already implemented.

So we have to look for a little bit older versions.

=> When was the ability to scroll in the POIs implemented ? (The same build since when we got these big icons for the POIS, I suppose)

Greetings Jörg

comment:13 Changed 10 years ago by tegzed

Yes,you are right, POI list is using the same problematic widget as bookmark list. Making POI lists scrollable was implemented before bookmark scrolling. Maybe the widget code is added with the POI scroll feature. I will check this later.

comment:14 Changed 10 years ago by jrahe

Ok, some additional testing (hope, that will help you to fix the issue):

=========== POIs ===========
build #3610 (I downloaded it 19.10.2010, date in svn-repository is 24.10.2010) => POIs are not scrollable, graphic issue only in the upper row with icons, no grahic issue in the list of POIs

Some changes after 19.10.2010 (user "tryagain" did some from 20.-23.10.2010).
So with build #3623 (26.10.2010) we got the scrollable POIs including the graphic issue.

Older builds than #3610 are causing an error on my device. Navit won´t start.
"navit.log" says: "unable to include storage card".
After softreset: "get CommState? error"
I´ve tested it with the builds #3606 (13.10.2010) and #3609 (18.10.2010)
The build #3610 (19.10.2010) starts normally.

=========== bookmarks ===========
=> scrolling down bookmarks was fixed with build #3803 from "number6" (ticket 596) at 22.12.2010 (based on a patch from "Tryagain")
s.a. http://trac.navit-project.org/ticket/596

Greetings Jörg

comment:15 Changed 10 years ago by number6

  • Cc nick@… added

I'm afraid that I don't have contact info for Tryagain, save IRC and Wiki.

I tested this patch on WinCE, WinMo? (Treo 750 also) and openSUSE and I didn't get any of these issues.

comment:16 Changed 10 years ago by tryagain

Had a look at the problem, was able to reproduce it on Ubuntu.

It seems that issue appears in following cases:

  1. When using keyboard arrows to move selection from one item to another.
  1. When moving mouse with button pressed over items, not depressing the button.

Can anybody confirm that issue reproduces when and only when you have some GPS working source configured (having demo:// source seems to be enough)?

Changed 10 years ago by tryagain

Should fix all above issues with highlighting in Bookmarks and POIs.

comment:17 Changed 10 years ago by number6

  • Keywords gui internal POI added
  • Resolution set to fixed
  • Status changed from new to closed

Patch added in Revision 4422.

Thanks Tryagain

Note: See TracTickets for help on using tickets.