Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#797 closed defect/bug (fixed)

Speer warner does not work on Android

Reported by: benja1972 -2- Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

Still cannot understand why speed warner does not produce any warning on Android. I have Android 1.6 Use latest svn version of Navit. Side-by-side I put 'speed_warner' and 'tracking.item.route_speed' in my OSD layout. On almost all roads (in France) route_speed show me speed limit for road. While driving sometime I exceed this limit. Speed_warner is silent all the way. And even I cannot see any visual indication on screen. Only big grey circle (not a zero). My speed_warner line in navit.xml

<osd enabled="yes" type="speed_warner" x="-200" y="-149"  w="100" h="100" speed_exceed_limit_offset="10" speed_exceed_limit_percent="10" announce_on ="1" font_size="800" background_color="#00000000" /> 

Change History (6)

comment:1 Changed 10 years ago by tegzed

is tracking enabled in your navit.xml? is there maxspeed tag in your osm data?

comment:2 Changed 10 years ago by benja1972 -2-

Yes tracking is enabled (stick to road). How can I check maxspeed tag in my OSM data? My area of driving is like this http://osm.org/go/0CUO6qAu

comment:3 Changed 10 years ago by tegzed

I guess you don't have osm maxspeed data. You can set default maxspeed values for different navit road types by setting roadprofile tags' maxspeed attribute in navit.xml. Please see http://wiki.navit-project.org/index.php/On_Screen_Display#speed_warner how to do this and how speed warner works.

comment:4 Changed 10 years ago by korrosa

I can confirm that inside the area provided there are no maxspeed tags in the OSM data. Looking slightly further afield, the maxspeed tags start to appear on the southern sections of the N57/E23, and the Rue Luxembourg north to the N73, which itself also has a maxspeed tag.

comment:5 Changed 10 years ago by benja1972 -2-

  • Resolution set to fixed
  • Status changed from new to closed

Ok, I see. I will close the ticket. Nevertheless it would be nice if speed_warner can take values from root_speed. For me it make sense and give good reference on .speed limit when driving. Add maxspeed tag to road profile is good idea if you drive in one country which is not my case. Moreover I provide navit.xml for some people in Russia and don't want add maxspeed corresponding to France road profile.

comment:6 Changed 10 years ago by tegzed

We had some discussion about this topic before (see ticket #609). I initially implemented speed warner to use osm maxspeed if exists in the first place then roadprofile maxspeed if it is set in roadprofile then roadprofile speed (that is accessible as route_speed in text osd label or speed attribute in navit.xml roadprofile tag). After some discussion we dropped fallback to route_speed/roadprofile.speed since it is not a speed limit, rather a typical speed for the road. I suggest you to set roadprofile maxspeed in your navit.xml for each road types for your country and you will have always some estimate for the speed limit. (the usage of roadprofile.maxspeed based estimate is displayed with a ~ prefix in speed warner )

Note: See TracTickets for help on using tickets.