Opened 12 years ago

Closed 11 years ago

#80 closed defect/bug (wontfix)

Crash on exit

Reported by: hawke Owned by: somebody
Priority: major Milestone: version 0.1.0
Component: gui/cegui Version: git master
Severity: Keywords:
Cc:

Description (last modified by KaZeR)

Navit crashes when I exit it.

Backtrace:
(gdb) bt
#0  0xb7ef4410 in __kernel_vsyscall ()
#1  0xb7cc4f35 in raise () from /lib/tls/i686/cmov/libc.so.6
#2  0xb7cc68b1 in abort () from /lib/tls/i686/cmov/libc.so.6
#3  0xb7cbe08e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#4  0xb734079a in ?? () from /usr/lib/libfontconfig.so.1
#5  0xb7356708 in ?? () from /usr/lib/libfontconfig.so.1
#6  0xb7356734 in ?? () from /usr/lib/libfontconfig.so.1
#7  0x00000200 in ?? ()
#8  0xb7356763 in ?? () from /usr/lib/libfontconfig.so.1
#9  0xb734073e in ?? () from /usr/lib/libfontconfig.so.1
#10 0xb70df408 in ?? () from /usr/lib/libGLC.so.0
#11 0xbfdcc268 in ?? ()
#12 0xb70cd09c in fini () from /usr/lib/libGLC.so.0
Backtrace stopped: frame did not save the PC

Change History (5)

comment:1 Changed 12 years ago by KaZeR

  • Description modified (diff)

comment:2 Changed 12 years ago by hawke

This may also be relevant. It is printed out before the crash

navit: fccache.c:512: FcCacheFini?: Assertion `fcCacheChains[i] == ((void *)0)' failed. Aborted (core dumped)

comment:3 Changed 12 years ago by mattcallow

This is caused by a call to FcFini? in the quesoglc library. It only seems to occur if the sdl gui is built, but not enabled in navit config. My testing shows the following:

  • --disable-gui-sdl then configure gtk gui in navit.xml => no crash
  • --disable-gui-sdl then configure sdl gui in navit.xml => Navit does not run (as expected - no gui)
  • --enable-gui-sdl then configure gtk gui in navit.xml => crash
  • --enable-gui-sdl then configure sdl gui in navit.xml => no crash

I suggest, as a work-around, configuring without sdl if you do not intend to use it (you'll need to do a make clean as well, to remove the old opengl libs)

comment:4 Changed 11 years ago by KaZeR

  • Component changed from core to gui/cegui

comment:5 Changed 11 years ago by KaZeR

  • Resolution set to wontfix
  • Status changed from new to closed

cegui support will probably be dropped.

Note: See TracTickets for help on using tickets.