Opened 9 years ago

Last modified 8 months ago

#811 new defect/bug

Android: navit.mo is only created for system locale, not for language setting in xml

Reported by: thomasah Owned by: cp15
Priority: minor Milestone: version 0.6.0
Component: port/android Version: git master
Severity: Keywords: languages, i18n
Cc:

Description

Tested with Android svn r4383: /data/data/org.navitproject.navit/locale/de/LC_MESSAGES/navit.mo is only created when starting Navit with a de_DE locale, so setting language="de_DE" in /sdcard/navit/navit.xml only works after having started Navit with this locale once. After that using a different locale is no problem.

Change History (3)

comment:1 Changed 6 years ago by usul

  • Keywords languages i18n added
  • Milestone set to version 0.5.1
  • Priority changed from major to minor

I'm not sure, but maybe this bug also appears at the OpenPandora? build. So the build script needs to be checked, if all translations are compiled.

Looks like a ugly bug that might confuse people, as they expect us "to be translated to 27+ languages" ;) So I schedule it for 0.5.1 hotfix

comment:2 Changed 2 years ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Milestone changed from version 0.5.1 to version 0.5.2

This ticket was pushed back in order to bring 0.5.1 out soon.

comment:3 Changed 8 months ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Milestone changed from version 0.5.2 to version 0.6.0

Ticket retargeted after milestone closed

Note: See TracTickets for help on using tickets.