Opened 9 years ago

Closed 6 years ago

#838 closed defect/bug (fixed)

Fullscreen mode dont work on Android

Reported by: prescott66 Owned by: kamikaaze
Priority: major Milestone: version 0.5.1
Component: port/android Version: git master
Severity: normal Keywords: display, fullscreen, patches
Cc: https://wiki.navit-project.org/index.php/user:thomasah, cp15

Description

When i switch Navit to fullscreen mode, it is allways in window mode, but icon is changed to fullscren mode.

phone: Samsung Galaxy 3, Android 2.2

Attachments (2)

fullscreen.diff (10.0 KB) - added by godfryd 8 years ago.
patch with support for toggling fullscreen on Android
fullscreen-v2.diff (2.1 KB) - added by kamikaaze 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by thomasah

  • Cc https://wiki.navit-project.org/index.php/user:thomasah added

confirmed on Motorola Defy, Android 2.1 (i.e. the status bar is still displayed)

comment:2 Changed 9 years ago by benja1972 -2-

confirmed on Archos 5IT, Android 1.6

Changed 8 years ago by godfryd

patch with support for toggling fullscreen on Android

comment:3 Changed 7 years ago by usul

  • Cc cp15 added
  • Keywords display fullscreen added
  • Milestone set to version 0.5.1

Was this patch applied yet? Does this bug still occur?

Changed 6 years ago by kamikaaze

comment:4 Changed 6 years ago by kamikaaze

  • Severity set to normal

The patch completes the callback to the fullscreen call. Basically the same as the diff supplied by godfryd just without storing the shared preferences, since those will be overwritten everytime Navit starts.

comment:5 Changed 6 years ago by kamikaaze

  • Owner changed from cp15 to kamikaaze
  • Status changed from new to assigned

comment:6 Changed 6 years ago by kamikaaze

  • Keywords patches added

comment:7 Changed 6 years ago by tryagain

  • Resolution set to fixed
  • Status changed from assigned to closed

The patch is applied with r5710

Note: See TracTickets for help on using tickets.