Opened 8 years ago

Closed 4 years ago

#844 closed defect/bug (Incomplete/Missing infos)

CPU trash when "Lock on road" is disabled

Reported by: niccolo rigacci Owned by: KaZeR
Priority: major Milestone: version 0.5.1
Component: core Version: git master
Severity: normal Keywords: performance, routing, gps
Cc:

Description

I'm running Navit SVN 4445 on the OpenMoko FreeRunner with Debian Sid.

Whenever I switch off the "Lock on road" option, the CPU usage raises from 35% to above 90%, then the program becomes unusable. If I switch again to Lock on road (eventually before systm trashing), the CPU usage returns to normal.

May be this issue is related to #422.

The problem exists also on my netbook (Debian Squeeze), where CPU usage raises from 1% to 50%. Here the problem is obviously less noticeable.

Let me know if I can help with more help. I can recompile Navit by myself.

Change History (4)

comment:1 Changed 8 years ago by korrosa

Thinking about it, this also happens to me. I can't provide any numbers as I've never looked too closely (I'm on a netbook too, so as mentioned the problem is less noticeable), but will check and update.

This issue is almost definitely the same as #422 - tracking (in xml) == lock on road (in GUI) as far as I'm aware.

comment:2 Changed 8 years ago by woglinde

Hi,

please try to run oprofile with navit and report as back, which function goes beserk.

http://oprofile.sourceforge.net/examples/

http://oprofile.sourceforge.net/doc/overview.html#getting-started

Bye Henning

comment:3 Changed 6 years ago by usul

  • Keywords performance routing gps added
  • Milestone set to version 0.5.1

This issue needs to be confirmed/neglet for the current SVN

comment:4 Changed 4 years ago by kazer

  • Resolution set to Incomplete/Missing infos
  • Severity set to normal
  • Status changed from new to closed

Need more informations as I never witnessed this myself, including testing on a raspberry pi. Please reopen if you can provide more details.

Note: See TracTickets for help on using tickets.