Opened 6 years ago

Closed 4 years ago

#849 closed defect/bug (fixed)

CMake build fails on Ubuntu 11.04 Natty Narwhal

Reported by: momcilo majic Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

I'am using jenkins + cmake to build a snapshot of navit. Recently I've upraded to Ubuntu 11.04 Natty Narwhal.

It seems cmake is unable to fidn glibconfig.h

Once the cmake is invoked, cmake failes to find glibconfig.h

Apparently, the issue is caused by the multiarch support being introduced to both debian and ubuntu.

This is most likely not a bug within navit.

It is reported at: https://bugs.launchpad.net/ubuntu/+source/cmake/+bug/751940 http://www.cmake.org/Bug/view.php?id=12037

Change History (4)

comment:1 Changed 6 years ago by momcilo majic

./autogen.sh && ./configure && make works just fine.

comment:2 Changed 6 years ago by antenna

Did you install all dependencies needed?

comment:3 Changed 6 years ago by momcilo majic

Yes, I did.

Following works for sure: ./autogen.sh && ./configure && make works just fine.

It works because it relies on pkgconfig, which was properly configured to avoid architecture conflict.

Unfortunately cmake is currently unaware of this change debian and ubuntu are pushing.

Please check the related bug reports at launchpad and cmake.org

The is not an issue for your project (since this is only alternative build system), but you need to be aware of it.

It is still possible to workaround this within cmake scripts, but that is not an elegant solution.

For now it is sufficient to keep this issue visible for the sake of others.

comment:4 Changed 4 years ago by usul

  • Resolution set to fixed
  • Status changed from new to closed

I just can say that it works out of the box on ubuntu 12.10 http://wiki.navit-project.org/index.php/Linux_development Please update!

issue seems to be outdated, so closed for cleanup

Note: See TracTickets for help on using tickets.