Opened 7 years ago

Closed 5 years ago

#853 closed defect/bug (fixed)

Fails to read data from gpsd 2.96

Reported by: me.yahoo.com/a/mxotqsqhhcwj4acyk6aomkoami9p5a--#a28cb Owned by: KaZeR
Priority: major Milestone: version 0.5.0
Component: core Version: git master
Severity: Keywords: gps, gpsd
Cc:

Description

OS: Gentoo gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo-r1 x86_64 cgps finds the location, navit seems to totally ignore the data. Results: Position is not displayed, navigation not possible

Solution: Downgrade to gpsd-2.95-r1 and recompilation of Navit against downgraded version of gpsd

Change History (3)

comment:1 Changed 7 years ago by bernd zeimetz

16:57:23 < bzed> gpsd 2.96 changed the api yet again. and somehow I think it will change for 3.0 again 
                 (... for the last time then...)
16:57:50 < bzed> cp15, borsten ^
16:58:39 < bzed> that is the reason why I did not yet upload 2.96 to debian. I'll wait for 3.0 which 
                 will be released this month
16:59:36 < borsten> ah, ok
16:59:58 < borsten> i think i was the first hwo greated a 2.96 on gentoo too
17:00:51 < borsten> created*

comment:2 Changed 7 years ago by woglinde

Hi,

please try the actual svn ot should give you position with gpsd 2.96, but logging nmea stream will ot work.

Bye Henning

comment:3 Changed 5 years ago by usul

  • Keywords gps gpsd added
  • Resolution set to fixed
  • Status changed from new to closed

Currently gpsd 3.4 is shipped for example at Ubuntu and nobody claims about problems, so I expect this issue as fixed.

But if anybody has problems, please reopen it at anytime.

Thanks for pointing us to this problem!

Note: See TracTickets for help on using tickets.