Opened 9 years ago

Closed 9 years ago

#872 closed defect/bug (fixed)

[valgrind] Uninitialized read - Bookmarks

Reported by: pini Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc: http://wiki.navit-project.org/index.php/user:pini

Description

Hi,

Some days ago valgrind triggered this error which I'm not able to reproduce anymore. Anyway, looking at the code, I think it needs a fix.

Please see the attached patch.

Thanks.

Attachments (1)

valgrind-bookmarks-zeroing-offsets.patch (655 bytes) - added by pini 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by pini

comment:1 Changed 9 years ago by pini

  • Cc http://wiki.navit-project.org/index.php/user:pini added

comment:2 Changed 9 years ago by woglinde

  • Resolution set to fixed
  • Status changed from new to closed

Hi,

thanks for the patch was applied with revision 4510 see http://navit.svn.sourceforge.net/viewvc/navit?view=revision&revision=4510

Bye Henning

Note: See TracTickets for help on using tickets.