Opened 9 years ago

Closed 9 years ago

#878 closed defect/bug (fixed)

Android: Auto-downloading map "not enough space" when there IS enough space

Reported by: c rauch Owned by: cp15
Priority: major Milestone:
Component: port/android Version: git master
Severity: Keywords: android map download
Cc:

Description

Always Errors like "not enough space", and abort's download, map austria (with about 250MB), Space left on SD 3,8 GB, Space left on internal phone memory 780 MB...

Change History (6)

comment:1 Changed 9 years ago by zoff99

i have that also since a long time on galaxy tab and on galaxy S II and on galaxy S. market version is fine.

comment:2 Changed 9 years ago by echtetonino

I can confirm this on the Galaxy S. Uninstalling svn version and installing the market version allows the download to go ahead.

comment:3 Changed 9 years ago by korrosa

  • Component changed from core to port/android
  • Keywords map download added; htc desire z removed
  • Owner changed from KaZeR to cp15
  • Summary changed from HTC Desire Z, Latest build for Z, Auto-Downloading Map to Android: Auto-downloading map "not enough space" when there IS enough space

comment:4 Changed 9 years ago by ham73tux

I have the same problem on a new Archos 70, 8GByte + additional 16 GByte SD card - plenty of space. This device runs Android 2.2. Can't install marketplace version of Navit (seems to be for 2.1 only?). I'd like to request to change priority to "blocker": I can't run Navit at all.

comment:5 Changed 9 years ago by ham73tux

Had an IRC chat with cp15 today, and a change was applied right away. The latest build (navit-svn-4659.apk 22-Jul-2011 23:17 7.9M) fixes the download issue, my device is currently downloading a map of the US. Thanks cp15 for your prompt work on this!

comment:6 Changed 9 years ago by korrosa

  • Resolution set to fixed
  • Status changed from new to closed

As mentioned, should be fixed in http://navit.svn.sourceforge.net/navit/?rev=4659&view=rev

If you're building from svn, please update and rebuild. You can also get the latest nightly apk builds from http://wiki.navit-project.org/index.php/Navit_on_Android#Install_nigthly_development_verions_of_Navit_from_the_Website_.28no_root_required.29_.5Bless_recommended.5D

Please re-open if you find the problem persists, and note the version number of Navit you are using.

Note: See TracTickets for help on using tickets.