Opened 9 years ago

Closed 5 years ago

#914 closed defect/bug (worksforme)

Android: Integrated map downloader fails to install a succesfully downloaded map

Reported by: kurtmyles Owned by: cp15
Priority: critical Milestone: version 0.5.1
Component: port/android Version: git master
Severity: normal Keywords: map, binfile, download
Cc:

Description (last modified by usul)

Android Navit V 0.5.0-4281

  • Samsung Vibrant 3g with android 2.2
  • Tried to download USA map (no AL or HI)

Observed Navit creates file /mnt/sdcard/navitmap.tmp size 2.23 gig Navit lists the file size as 2114 mb before the download.

  • If I delete the file and redownload, file is recreated.
  • Looks like map downloads ok but map install fails
  • Tried using latest SVN, same results.

Thanks much for the work!

Change History (5)

comment:1 Changed 9 years ago by korrosa

  • Component changed from mapdrivers/OSM to port/android
  • Summary changed from Android Map Download Fail to Android: Integrated map downloader fails to install a succesfully downloaded map

So if I read the ticket correctly, you can download maps without any problems but you fail to see them within Navit? If this is the case, I'm gonna re-name the ticket so it's a little more descriptive. Please change it back if I have the wrong end of the stick.

comment:2 Changed 9 years ago by kurtmyles

You read correctly. As far as I can tell, the download succeeds. At the completion, the filename remains navitmap.tmp, instead of navitmap.bin.

comment:3 Changed 9 years ago by bovist

I have a similar problem: I used the Android app to download the Western Europe map overnight via wifi. According to my rooter's log file, I had been permanently connected to the internet during the download. When I returned in the morning, the download showed 0% and and not advancing. I aborted it. In the navit directory, however, there is a file "navitmap.tmp", size 2.3 GB. The size of the Western Europe map is 2.7 GB. I have the impression that there is no way to make use of the data already downloaded when invoking another download of the same map? In my oppinion a download procedure that downloads so large files should be able to reuse already downloaded data.

comment:4 Changed 7 years ago by usul

  • Description modified (diff)
  • Keywords map binfile download added
  • Milestone set to version 0.5.1
  • Priority changed from major to critical

sounds somewhat critical, I schedule for hotfix

comment:5 Changed 5 years ago by kazer

  • Resolution set to worksforme
  • Severity set to normal
  • Status changed from new to closed

I've been able to download maps successfully. I will close as worksforme, but please reopen if needed.

Note: See TracTickets for help on using tickets.