Opened 9 years ago

Closed 7 years ago

#919 closed defect/bug (invalid)

Buggy routing at cloverleaf junctions of single-carriageway streets

Reported by: mvglasow (2) Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

When two major roads cross with a "cloverleaf" junction (i.e. free of level crossings), Navit gives buggy route instructions for switching from one road to another if the destination road has one single carriageway for both directions: often, this involves taking the exit that leads to the destination road, but in the opposite direction, and then doing a sharp left/u-turn, cutting through a lane of traffic. (See attached picture.) Driving this way is certainly not intended and most likely prohibited, so Navit should behave accordingly.

The problem is that these junctions usually don't have turn restrictions in OSM. Navit apparently finds that taking the link for the "wrong" direction and then doing a U-turn is slightly shorter/faster than taking the "correct" link.

One junction at which I encountered this is this one: http://www.openstreetmap.org/?lat=57.00903&lon=24.30876&zoom=15&layers=M

I came from the A2, eastbound, and wanted to continue on the A4, northbound.

Attachments (1)

Buggy cloverleaf junction.png (73.0 KB) - added by mvglasow (2) 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by mvglasow (2)

comment:1 Changed 9 years ago by mvglasow (2)

Gray is the route I would have expected, red is the route Navit gave me.

comment:2 Changed 9 years ago by mvglasow (2)

After some research, the OSM wiki suggests that "jughandle" junctions (and thus also cloverleaf junctions) should use turn restrictions where maneuvers are not already prohibited by oneway restrictions. Which means the junctions on which I was experiencing these errors are lacking them.

Other opinions?

comment:3 Changed 7 years ago by mvglasow (2)

  • Resolution set to invalid
  • Status changed from new to closed

After some time in which I encountered a number of such junctions, I found that most use turn restrictions. This may be a bit of work, as each of the 8 ramps involved would get two turn restrictions (one at each end), resulting in up to 16 restrictions, but appears to be the way to go. Closing as "invalid", as the error was due to bad data and not a bug in Navit.

Note: See TracTickets for help on using tickets.