Opened 8 years ago

Closed 6 years ago

#921 closed defect/bug (duplicate)

Misleading turn instructions at motorway branchings

Reported by: psoding Owned by: KaZeR
Priority: major Milestone: version 0.5.0
Component: core Version:
Severity: Keywords: highhway, routing, lane, intersection, car
Cc:

Description

On motorway/freeway/autobahn branchings, the voice instructions "right"/"left" appear to be based (sometimes/often/principally?) on the absolute change of direction of the route, without regard of other lanes. Thus e.g. it will instruct to keep "right" although the other (wrong) lane at the same place is turning more to the right -> very confusing. The directions should be relative to the other lane(s).

Change History (7)

comment:1 Changed 8 years ago by polarbear_n

I think the problem is not the lane alone.

A main problem is that exit numbers are not announced, and announcing the change of road classification seems to be insufficient.

Changing into a differently classified road (tertiary to secondary, or motorway to link), or changing road ref numbers should be considered as an important navigation event, even if the change is nearly straight.

Vice versa, staying on the same road classification with the same ref should be announce as 'keep on' instead of announcing a turn.

I know a spot where the motorway makes a very slight right bend while the ramp goes straight, and being on the M7 I'm getting told to 'turn right into' the very same M7.

So if you have to exit on that spot, and subsequently to go right over the bridge, Navit just says to 'turn right soon', which in fact means straight into the exit lane and then right over the bridge over the motorway, but as the exit is ignored, the user is tempted to stay (right) on the motorway and misses the exit.

comment:2 Changed 8 years ago by mvglasow (2)

Consider also #660 which sort of discusses the contrary case: the road turns, another one goes off straight, both split where the turn is. In one of the cases mentioned, both roads involved are primaries; in the other case, the one that turns is a trunk while the one that goes straight is a primary. In both cases, I would want a "keep left" or "turn left" instruction because it is not visible from the road geometry/lane markings where to go.

Motorways are different: usually it is easy to tell which is the motorway and which is the ramp. Also, off-ramps usually exit to the right in countries that drive on the right (to the left in countries which drive on the left), so most savvy drivers would keep to the center lane unless instructed otherwise and no turn instruction is needed for staying on the same road.

Note, however, that there are exceptions to the rule:

  • Germany has one motorway exit that is to the left (as far as I know, there is only one in the whole country)
  • near Mulhouse, France, when approaching the A35/A36 junction from north, you have to keep right in order to stay on the A36 towards Basel; keeping left will take you onto the A35 to Mulhouse
  • near Memmingen, Germany, at the A7/A96 junction, when approaching it from west, you have to keep right to stay on the A96 towards Munich; the left lane will take you onto the A7 towards Ulm.

Since these instructions are few, but counterintuitive, here I would want turn instructions ("keep right"/"keep left") in either case.

Trunk roads are a special case: they may have motorway specs (separate carriageways, no level crossings), hence motorway rules apply; in others they may have U-turns or a single carriageway, which makes them more similar to primary roads.

comment:3 Changed 7 years ago by karl siegemund

If it is a road with lanes (as most motorways are), I would like the description to be similar to "outermost left lane" or "outermost right lane", or "second lane from the right" (whatever fits best).

If the road with the highest level makes a turn while a lower level road continues to go straight, maybe an instruction like "follow the main road" would be in order.

comment:4 Changed 7 years ago by greyeagle.myopenid.com

The core issue seems how Navit calculates the turning direction. I have experienced the following:

A freeway "splits" towards two new or at least one separating lane. It's like a Y coming from the stem of that Y. Now Navit is looking for the junction point and checks which way the next polyline segment is deviating from the one before the junction point (node). Now if that first polygon element after the junction node is going a little bit to the right (because roads are almost never exactly straight and the junction is for instance located within a right curve) Navit will announce: turn right. However the real road to drive will eventually turn away left, just not on that spot because the Y is not yet completely driven. Navit should take into account more polygon sections (and especially the route graph) and actually check if the actual route is turning, rather than only looking at the first polygon section after that point. It is rally confusing and happens all the time that Navit exchanges right for left and vice versa in such situations. Very confusing indeed. One could say this is a map problem but I do not believe this is true. Navit should not be as sensitive and have a more robust and reliable algorithm here, taking into account the route graph rather than the road alone.

comment:5 Changed 7 years ago by tryagain

Please also note that route graph is less dense in the middle of the route than near its endpoints. Less significant roads more than 40 km away from both endpoints are dropped when the route graph is built. So they may not be used when preparing a navigation instruction.

So, to get right navigation instructions it may be wise to use not ROUTE graph but ROAD one. The latter can be built for some small window around current position (or better around nearest part of the planned route) and rebuilt each time position leaves that window.

comment:6 Changed 7 years ago by robotaxi.myopenid.com

#795 is more or less the same complaint. It contains a patch that fixes the confusing left/right issue. It considers the alternative turns of a current point compared to the route turn and generates the corresponding announcement.

comment:7 Changed 6 years ago by usul

  • Keywords highhway routing lane intersection car added
  • Resolution set to duplicate
  • Status changed from new to closed

As the other ticket is more uptodate, I will mark this as a dupe to establish a linking and focus the discussion on one single point.

Note: See TracTickets for help on using tickets.