Opened 9 years ago

Closed 9 years ago

#924 closed defect/bug (fixed)

cmake error with fribidi

Reported by: fred labrosse Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

Compiling from svn I get:

$ make
fatal: Not a git repository (or any parent up to mount parent )
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
Already at toplevel, but .git not found
 at /usr/libexec/git-core/git-svn line 277
-- Found Subversion: /usr/bin/svn (found version "1.6.17")
-- SVN-version 4728
[  0%] Built target version
[  0%] Built target fib
[  6%] Built target navit_core
[  6%] Built target navit
[  6%] Built target navit_config_xml
[  7%] Built target support_shapefile
[  7%] Building C object navit/font/freetype/CMakeFiles/font_freetype.dir/font_freetype.c.o                                                                     
gcc: no input files                                                             
/bin/sh: -I/usr/include/fribidi: No such file or directory
make[2]: *** [navit/font/freetype/CMakeFiles/font_freetype.dir/font_freetype.c.o] Error 127
make[1]: *** [navit/font/freetype/CMakeFiles/font_freetype.dir/all] Error 2
make: *** [all] Error 2

My cmake is not too good (in particular I don't know how to make it display the actual compilation line), but from the error message, it seems that it is try to compile without a target. But I might be wrong. It goes without saying that I have fribidi:

$ ls -l /usr/include/fribidi
total 80
-rw-r--r-- 1 root root 11611 Dec 10  2010 fribidi.h
-rw-r--r-- 1 root root  5045 Dec 10  2010 fribidi_char_sets.h
-rw-r--r-- 1 root root   291 Dec 10  2010 fribidi_char_sets.i
-rw-r--r-- 1 root root  1748 Dec 10  2010 fribidi_char_sets_cap_rtl.h
-rw-r--r-- 1 root root  1822 Dec 10  2010 fribidi_char_sets_cp1255.h
-rw-r--r-- 1 root root  1817 Dec 10  2010 fribidi_char_sets_cp1256.h
-rw-r--r-- 1 root root  1887 Dec 10  2010 fribidi_char_sets_isiri_3342.h
-rw-r--r-- 1 root root  1869 Dec 10  2010 fribidi_char_sets_iso8859_6.h
-rw-r--r-- 1 root root  1869 Dec 10  2010 fribidi_char_sets_iso8859_8.h
-rw-r--r-- 1 root root  1828 Dec 10  2010 fribidi_char_sets_utf8.h
-rw-r--r-- 1 root root   872 Dec 10  2010 fribidi_config.h
-rw-r--r-- 1 root root  2067 Dec 10  2010 fribidi_mem.h
-rw-r--r-- 1 root root 11242 Dec 10  2010 fribidi_types.h
-rw-r--r-- 1 root root  1029 Dec 10  2010 fribidi_types.i
-rw-r--r-- 1 root root  2108 Dec 10  2010 fribidi_unicode.h

Attachments (1)

makeError.txt (9.8 KB) - added by fred labrosse 9 years ago.
Output of "make VERBOSE=1"

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by rikky

Please attach the output of "make VERBOSE=1".

Changed 9 years ago by fred labrosse

Output of "make VERBOSE=1"

comment:2 Changed 9 years ago by fred labrosse

Output attached. The error is caused by an extraneous ';' just before "-I/usr/include/fribidi".

comment:3 Changed 9 years ago by fred labrosse

The ';' comes from (or at least is mentioned in) the variable TARGET_FLAGS in build/navit/font/freetype/CMakeFiles/font_freetype.dir/flags.make

comment:4 Changed 9 years ago by rikky

Ah, that is a known bug in cmake 2.8.5. I try to workaround this bug, but in the meantime you could downgrade to cmake 2.8.4.

comment:5 Changed 9 years ago by rikky

Ok, should be fixed with rev 4745

comment:6 Changed 9 years ago by fred labrosse

Fixed indeed. Thanks.

comment:7 Changed 9 years ago by korrosa

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.