Opened 9 years ago

Closed 9 years ago

#928 closed defect/bug (fixed)

Android - GPS receiver doesn't stop working after exiting navit

Reported by: crystalgfan . Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords: Android - GPS receiver
Cc:

Description

Just experienced this weird behavior with cmake svn 4746.
When closing navit the GPS receiver icon in the status bar is still there or is still flashing in case of not having a fix. And it is still receiving because if you open for example the app GPS Test then it has immediately satellites in view, that's not the case if the receiver was off before.
Forthermore, if I disable GPS reception via built in button, then the icon is gone, but if I enable GPS again even after an hour the GPS icon starts flashing.
A similar behavior I had with svn 4696 and before but if you opened GPS Test and closed it then the GPS icon was gone, but with the latest it is still there and receiving. Besides, all other GPS utility apps work as expected.
My solution so far: Using built in task manager to kill navit and the GPS icon in status bar is gone. Same result I get with clearing the memory. So I think something what resides in memory keeps the receiver still working.
Samsung Galaxy S
Custom Rom Android 2.2.1
Speedmod kernel k13d
ZSJPG Modem

Change History (6)

comment:1 Changed 9 years ago by rikky

Fix with revision 4751. I don't know the reason for this new behavior yet. Nevertheless, with this commit the GPS listener is freed when closing Navit and the icon should be gone at once.

comment:2 Changed 9 years ago by tegzed

Hello Rikky,

On my device (Motorola Defy, android 2.2) this change makes Navit restarting in an infinite loop. At least I think it is restarting. I see black screen for a couple of seconds then the map appears for a half second then i see the black screen again and so forth. With older versions this problem is not present.

comment:3 Changed 9 years ago by tegzed

Some extra info: if I disable gps receiver in the android settings menu navit is not restarting anymore but of course I cannot use it with disabled gps.

comment:4 Changed 9 years ago by rikky

I can't reproduce this behavior, so it would be great if you could attach a log to this bug. To capture the log you can install alogcat or catlog from the market.

If this is not possible, I will revert 4751 tomorrow.

comment:5 Changed 9 years ago by tegzed

Hi Rikky,

Sorry, I think the problem is caused by my wrong change to the text OSD that I forgot to remove from the code. The bug is triggered when there is something to display ie. on gps update. That's why i suspected this commit. After setting a layout without text osd the error disappearded. I'm sorry again and thanks for your work!

comment:6 Changed 9 years ago by rikky

  • Resolution set to fixed
  • Status changed from new to closed

ok, thanks for the update. I guess the ticket can be closed than.

Note: See TracTickets for help on using tickets.