Opened 6 years ago

Closed 2 weeks ago

#956 closed defect/bug (fixed)

Android - While routing Navit window disappears but is still there in notification bar

Reported by: crystalgfan . Owned by: cp15
Priority: major Milestone: version 0.5.1
Component: port/android Version: git master
Severity: normal Keywords: display, ui
Cc:

Description

I noticed an odd behavior when routing. The Navit window disappears but Navit still runs and is there in the notification bar. Just looks like one would switch to home screen but I didn't touch the device.
Not always but a few times it happened when just reaching the destination or close to it but one time it happened when there were 15 km to go.
If you tap on it in notification bar then the window opens again and Navit starts to route again.
The route was always about 80 km.
The Germany map was taken from here:
http://maps.navit-project.org/api/map/?bbox=5.185546875,46.845703125,15.46875,55.634765625
on October 13th.
First I noticed it with armv5te/svn 4838.

Samsung Galaxy S1, Android 2.2.1 Custom ROM (Taken from ROM kitchen, Speedmod kernel)

Change History (6)

comment:1 follow-up: Changed 6 years ago by crystalgfan .

Here my latest experiences. It still happens but not every time.
When pulling it back from notification bar it starts routing again and does it perfectly till destination. But it has lost a setting, autozoom has to be switched on again. That doesn't happen if I do switch to home screen manually.
Looking back I think the only change was that Navit switched automatically between day and night layout when on the way and routing. Any other changes I didn't do to the phone except updating to a newer svn version. I encountered the problem with these ones: 4838, 4831
In case of interest my navit.xml file can be found here:
http://pastebin.com/Q6DgVzpm

I'd like to ask what do I have to set in the navit.xml file in order to get an info about that in a log file? And where can the logfile be found?

comment:2 in reply to: ↑ 1 ; follow-up: Changed 6 years ago by tegzed

Hello Crystalgfan,

I'd recommend installing some application to analyze the logs on device (logcat or alogcat can be used for this). (I guess you cannot debug it via a pc during your trip).

Replying to crystalgfan:

Here my latest experiences. It still happens but not every time.
When pulling it back from notification bar it starts routing again and does it perfectly till destination. But it has lost a setting, autozoom has to be switched on again. That doesn't happen if I do switch to home screen manually.
Looking back I think the only change was that Navit switched automatically between day and night layout when on the way and routing. Any other changes I didn't do to the phone except updating to a newer svn version. I encountered the problem with these ones: 4838, 4831
In case of interest my navit.xml file can be found here:
http://pastebin.com/Q6DgVzpm

I'd like to ask what do I have to set in the navit.xml file in order to get an info about that in a log file? And where can the logfile be found?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 6 years ago by crystalgfan .

Replying to http://wiki.navit-project.org/index.php/user:tegzed:

(I guess you cannot debug it via a pc during your trip).


Hi tegzed,
That's true. Now I have an aLogcat logfile, can be found here:
http://pastebin.com/MuDCN5vy
Some explanations: I noticed that the Navit window was gone at 17:18 but don't know exactly when it really went away.
Before I had to go through a tunnel and had to stop because of a red traffic light. There was no GPS signal.
I remember when I went into the tunnel the window was still there.
Have a look at this and lines around:
11-08 17:16:37.788 E/Navit (18974): OnDestroy?
The phone is in a car dock that opens the Car Home screen. In order to get to alogcat and to save the log I had to pause the Carhome screen.

Hope this helps. Thanks in advance.

comment:4 in reply to: ↑ 3 Changed 6 years ago by crystalgfan .

Hello,

11 days later with about 7 times routing with Navit on the same route and similar time:
The Navit window stays on top, not any disappearance occurred. I may be wrong but the only difference now is that Navit doesn't has to switch to the night layout on the fly because I start this route late after sundown.

comment:5 Changed 4 years ago by usul

  • Component changed from core to port/android
  • Keywords display ui added; Android Navit window disappears removed
  • Milestone set to version 0.5.1
  • Owner changed from KaZeR to cp15

Summary:

  • navit minimizes from time to time
  • might be related to night layout

comment:6 Changed 2 weeks ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Resolution set to fixed
  • Severity set to normal
  • Status changed from new to closed

I think this one should be fixed. Because i don't have enough informations, i will mark this ticket as fixed. If the error is still existent please join the IRC and tell us about: https://wiki.navit-project.org/index.php/Contacts#IRC

Note: See TracTickets for help on using tickets.