Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#971 closed defect/bug (fixed)

Android - Aborting Navigation is broken

Reported by: crystalgfan . Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords: Aborting Navigation is broken
Cc: sebastian.leske@…

Description

With svn-4847 there's a strange behavior when trying to stop navigation.
This icon doesn't disappear and navigation is still active:
<img cond='navit.route.route_status&amp;52' src='gui_stop' onclick='abort_navigation()'><text>Stop Navigation</text></img>
Same results with and without fix or GPS signal available or not.
Additionally, navigation is still present if you shut down Navit and start it again.
Latest well working version was svn 4845 that I used for some time now, svn 4846 seems also to be ok.

Samsung Galaxy S
Custom Rom Android 2.2.1
Speedmod kernel k13d
ZSJPG Modem

Attachments (2)

stop_navigation_workaround.diff (1.1 KB) - added by tegzed 8 years ago.
workaround for the stop navigation crash
stop-navig-crashfix.diff (1.9 KB) - added by sleske 8 years ago.
Only call bookmarks_append_coord if coord!=NULL. Fixes crash when selecting "Stop Navigation".

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by martin bruns

Actually navit is crashing on android and linux by selecting Stop Navigation when using svn 4847.

I can confirm that 4846 is working on both systems.

M

comment:2 Changed 8 years ago by tegzed

I think the problem is introduced with the recent destination patch. I created a quick workaround(see the attached patch), but Sleske the author of the former destination patch should be asked to implement a better fix for the problem.

Changed 8 years ago by tegzed

workaround for the stop navigation crash

comment:3 Changed 8 years ago by sleske

Sorry, when making my patch, I didn't realize that bookmarks_append_coord will be called with pcoord *c==NULL when navigation is stopped by the user. This probably makes it crash :-/. I'll try to post a patch tomorrow.

comment:4 Changed 8 years ago by tegzed

Hi Sleske,

Thanks for the fix in advance. I think the former destination functionality is really useful, such minor problems are happening frequently.

Bye David

Changed 8 years ago by sleske

Only call bookmarks_append_coord if coord!=NULL. Fixes crash when selecting "Stop Navigation".

comment:5 Changed 8 years ago by sleske

The attached patch should fix the bug. I didn't realize that "Stop Navigation" is implemented internally by setting a new destination with coordinate NULL. Of course in that case no entry for a former destination should be written.

comment:6 Changed 8 years ago by tryagain

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 6 years ago by sleske

  • Cc sebastian.leske@… added
Note: See TracTickets for help on using tickets.