Opened 6 years ago

Closed 2 months ago

#974 closed defect/bug (fixed)

Android: UI does not properly respond to touchscreen events

Reported by: elhennig Owned by: mvglasow (2)
Priority: major Milestone: version 0.5.1
Component: port/android Version: git master
Severity: normal Keywords: input, ui
Cc: elhennig@…, http://wiki.navit-project.org/index.php/user:mvglasow, (2)

Description

On Android I have the problem, that sometimes the UI does not respond to the first touchscreen event but on the second triggering another action starting from the next page. It does not happen when I start navit the first time after a reboot.

I am running navit on a SGS I9000 on Gingerbread.

Change History (6)

comment:1 Changed 4 years ago by lars hennig

  • Cc elhennig@… added

comment:2 Changed 4 years ago by usul

  • Keywords input ui added
  • Milestone set to version 0.5.1

Please give us more details on that, maybe you can record a short video?

comment:3 Changed 2 years ago by mvglasow (2)

  • Severity set to normal

See #1297, which might be describing the same issue. Can you carry out the tests described in that ticket? (You may not need to mess with navit.xml – either you're not using one, or it's having the same issue as the default one.)

comment:4 Changed 2 years ago by mvglasow (2)

  • Cc http://wiki.navit-project.org/index.php/user:mvglasow (2) added

r6088 should fix the behavior you're describing. Could you test that version and let us know if the issue has gone away?

comment:5 Changed 2 years ago by mvglasow (2)

  • Owner changed from cp15 to mvglasow (2)

comment:6 Changed 2 months ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Resolution set to fixed
  • Status changed from new to closed

Probably fixed, please open a new ticket if the issue is still occurs

Note: See TracTickets for help on using tickets.