Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#975 closed enhancement/feature request (duplicate)

Bookmark handling

Reported by: elhennig Owned by: cp15
Priority: major Milestone:
Component: gui/gtk Version: git master
Severity: Keywords:
Cc: sebastian.leske@…

Description

A bookmark is set as destination as sson as it is selected from the list before explicitly selecting it as destination. This makes it impossible only to rename or move the bookmark entry for example.

Change History (12)

comment:1 Changed 8 years ago by tryagain

Seems to work for me fine on Ubuntu/navit svn r4643 with <gui type='internal'

Can you please report some details: what platform do you run it on, which navit version are you running, what gui do you use?

And if you have noted, in which version it was last working fine?

Well, I confirm it is broken and behaves as you described for <gui type='gtk'

Though I have not used the "gtk" gui extensively before so I don't know if it was ever allowing bookmarks operations like it's done in the "internal" gui.

Last edited 8 years ago by tryagain (previous) (diff)

comment:2 Changed 8 years ago by sleske

Yes, the GTK gui does not currently allow editing of bookmarks. It's a good idea for a new feature, though.

comment:3 Changed 8 years ago by sleske

  • Component changed from core to gui/gtk
  • Owner changed from KaZeR to cp15
  • Type changed from defect/bug to enhancement/feature request

comment:4 Changed 8 years ago by sleske

  • Cc sebastian.leske@… added

comment:5 Changed 8 years ago by elhennig

I am running navit 4858 on Android and I am using internal gui

comment:6 Changed 8 years ago by tryagain

Self-built svn 4858 works fine for me on HTC Wildfire S/Android/internal gui (and on Ubuntu, too).

Well, that features are not so intuitive... You get back to main menu when you cut or paste a bookmark. So you have to navigate to bookmarks menu again to review your changes.

comment:7 Changed 8 years ago by sleske

Ok, that changes things. That's a bug :-).

Unfortunately, I cannot reproduce this (also internal GUI on rev. 4858). Please post for us:

  • the platform you are running on
  • your navit.xml
  • your bookmarks.txt
  • the exact steps to follow to replicate the problem

If your bookmarks.txt contains destinations that you'd like to keep private, try to create a fresh one that demonstrates the problem.

Then we can hopefully attack this problem...

comment:8 Changed 8 years ago by elhennig

OK, I experimented a bit more and the problem is slightly different from what my first impression was: As I used my "home" bookmark for testing I thought the route was activated as soon as I pressed the bookmark. However, the routing to "home" start everytime I launch navit even if I cancel the route prior to quitting the app. BTW, "home" was the last destination in the recent destinations list.

Bookmark handling is working fine, but canceling the route cause a problem when starting navit again. I then deleted destination.txt and the problem was gone. After specifying a new route a new destination.txt was created and after canceling the routing and restarting navit, the route was activated automatically again.

Should I open another ticket for this, does this belong to ticket #971 or should I change this ticket accordingly?

comment:9 follow-up: Changed 8 years ago by sleske

Thanks for the detailed input. So the real bug is that if you cancel the route, the route "comes back" if you restart Navit.

I believe this is by design. AFAIK, on startup Navit reads the list of former destinations, and automatically starts navigation to the most recent destination (actually, navigation starts as soon as a position is available, either via GPS or by manually setting the current position from the menu).

So the question is if this is the right behaviour. I assume it was meant to help the user, because Navit automatically resumes navigation if you restart Navit for some reason.

In my opinion, this restoring of the last route should only happen if the route was active when Navit was closed. So:

  • Start navigation; close Navit; restart Navit -> route still active
  • Start navigation; stop navigation; close Navit; restart Navit -> route not active

Does this make sense? Then I would turn this into an enhancement request.

BTW, #971 is a different problem (it was about a crash).

comment:10 in reply to: ↑ 9 Changed 8 years ago by elhennig

Replying to sleske:

In my opinion, this restoring of the last route should only happen if the route was active when Navit was closed. So:

  • Start navigation; close Navit; restart Navit -> route still active
  • Start navigation; stop navigation; close Navit; restart Navit -> route not active

Does this make sense? Then I would turn this into an enhancement request.

Yes that's is exactly what navit did in the past. Now I cancel the route and after closing navit and starting it again the route is active again.

I asked for #971 because I think, that the problem occured in the versions after that patch was applied. navit always starts routing to the last destination listed in destination.txt

comment:11 Changed 8 years ago by sleske

  • Resolution set to duplicate
  • Status changed from new to closed

comment:12 Changed 8 years ago by sleske

Yes that's is exactly what navit did in the past. Now I cancel the route and after closing navit and starting it again the route is active again.

Ok, that's clearly a bug. As it happens, someone else noted this exact problem and reported #980. As #980 describes the problem quite well, I'm closing this bug as a duplicate.

Note: See TracTickets for help on using tickets.