Opened 8 years ago

Closed 7 years ago

#986 closed defect/bug (wontfix)

German espeak output in navit messes "ß" up on windows ce devices

Reported by: martin tlustos Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

On my windows ce device navit fails to pronounce the german special character "ß" (e.g. in "Straße"). Instead it starts spelling s - z - e. On the navit irc it was suggested that this might be a problem with the way the espeak function handles utf-8.

Change History (6)

comment:1 Changed 8 years ago by tryagain

What is your device locale? If it's not german I'd expect it going that way.

What is the language of navit voice directions on your device? If it's german, I take off following words.

Problem most probably is not related to utf-8 because I had no similar problems with Russian language on WinCE with Russian locale.

If I guessed the cause, to fix that, we need some means to change espeak locale.

Also you may try going to Control Panel of your Operating System and swithcing locale there. But I'm not completely sure what may (or may not) happen if you choose some locale unsupported by OS. Do it at your own risk and report here ;).

Last edited 8 years ago by tryagain (previous) (diff)

comment:2 Changed 8 years ago by martin tlustos

Well, my windows ce device only has us english as possible language locale, but I set navit to German via the navit.xml file. It now reads everything else fine. Is there a setting in navit.xml to change the espeak locale on windows ce devices?

comment:3 Changed 8 years ago by martin tlustos

Actually, espeak seems to use german locale anyway. I tried replacing the german voice files in espeak subfolder with the ones I have on my linux computer. It didn't work, rather messed speech up because linux uses a newer version of espeak (1.4.5 or so instead of 1.4.1 that is used in navit), but because I only replaced the german files, it showed that espeak used exactly those.

comment:4 Changed 8 years ago by martin tlustos

Any updates on this? The problem should not be in the locale settings, as other German special sounds (like ch, ü, ö and the like) are read ok. It's just the "ß" that is pronounced wrong, but as it appears in every street name (Straße), it's annoying. There's another sound(combination actually) that is pronounced wrong: The "demnächst," which is German for "soon", is pronounced "demnä-c-h-s-t". This one's not that bad though, as chs (ch-s) is a very rare combination in German.

comment:5 Changed 7 years ago by martin tlustos

Update: I installed espeak 1.4.1 on my computer and it spoke the ? and the chs well, so the problem seems to be with either navits port of espeak (unlikely) or the combination of navit being set to German while the device itself is us-english only.

comment:6 Changed 7 years ago by martin tlustos

  • Resolution set to wontfix
  • Status changed from new to closed

As the problem lies with a missing input locale on my win ce device rather than with navit, I'll close this ticket as won'tfix.

Note: See TracTickets for help on using tickets.