Opened 7 years ago

Closed 6 years ago

#991 closed enhancement/feature request (fixed)

Long-click menu needs simpler cancel method

Reported by: me.yahoo.com/a/t8pxanggmzrce9fscf2wgwk_ozmtbyifgarr#f3b4e Owned by: kamikaaze
Priority: minor Milestone: version 0.5.1
Component: port/android Version: git master
Severity: normal Keywords: input, map,
Cc:

Description

  • Navit version: navit-svn-4871
  • Device: Samsung Galaxy Tab P1000
  • OS: Android 2.2

When long-press on map, the Position menu appears. Only available option in this menu is "Route to here"

The problem is that cancelling this menu is done only with pressing menu, back or search button on the device.

Pressing one of the device buttons may be difficult in some conditions. It may be difficult to press one of the buttons when in a running car. And during the night the buttons can not be seen as they are not lit all the time. There is one more issue here: it is very easy to call this menu by mistake. It is very easy to call this menu when scrolling and zooming the map.

We should be able to cancel this menu easier. The best solution I see here is to cancel this menu by clicking anywhere on the map, outside the displayed menu.

Attachments (2)

route-to-here.png (116.9 KB) - added by me.yahoo.com/a/t8pxanggmzrce9fscf2wgwk_ozmtbyifgarr#f3b4e 7 years ago.
long click menu
cancel-menu.diff (13.3 KB) - added by kamikaaze 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by me.yahoo.com/a/t8pxanggmzrce9fscf2wgwk_ozmtbyifgarr#f3b4e

long click menu

comment:1 Changed 6 years ago by usul

  • Component changed from core to port/android
  • Keywords input map added
  • Milestone set to version 0.5.1
  • Owner changed from KaZeR to cp15
  • Priority changed from major to minor

This seems to be related to the android port only (couldn't reproduce it on Linux and WinCE).

Will schedule it to the next hotfix

comment:2 Changed 6 years ago by kamikaaze

  • Owner changed from cp15 to kamikaaze
  • Status changed from new to assigned

Changed 6 years ago by kamikaaze

comment:3 Changed 6 years ago by kamikaaze

The patch submitted adds a cancel button to the context menu which allows to cancel.

comment:4 Changed 6 years ago by kamikaaze

  • Resolution set to fixed
  • Severity set to normal
  • Status changed from assigned to closed

comment:5 Changed 6 years ago by sleske

  • Resolution fixed deleted
  • Status changed from closed to reopened

Erm, why was this closed? The patch has not been applied.

Is the patch tested? If yes, I can apply it and close the ticket.

comment:6 Changed 6 years ago by kamikaaze

I thought it was applied with this commit: http://sourceforge.net/p/navit/code/5654/

comment:7 Changed 6 years ago by kamikaaze

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.