Opened 8 years ago

Last modified 8 years ago

#1263 new defect/bug

CSV maps not working on Maemo4

Reported by: klosels Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: normal Keywords:
Cc: tryagain, sleske


I tried using the CSV map plugin on a Nokia N810 device (running Maemo4 "Diablo").

Loading the CSV plugin fails with the following error:

navit:plugin_load:can't load '/usr/lib/navit/map/', 
Error '/usr/lib/navit/map/ undefined symbol: g_hash_table_get_values'
navit:map_new:invalid type 'csv'

The reason seems to be that Maemo4 includes an ancient glib (2.0) which doesn't include g_hash_table_get_values which was introduced in 2.14. Maemo4 isn't updated since a long time, so getting a newer glib is not that easy. Using navit's own glib isn't that easy either, as 'tryagain' tried. Maybe someone familiar with the Maemo build could get it to work?

See also the original thread in the forum.

Change History (1)

comment:1 Changed 8 years ago by tryagain

Please try r5917 build or fresher when it will become available.

Last edited 8 years ago by tryagain (previous) (diff)
Note: See TracTickets for help on using tickets.