Opened 12 years ago

Closed 12 years ago

#646 closed defect/bug (fixed)

Text to speech not working anymore on Android 2.2

Reported by: florian Owned by: cp15
Priority: major Milestone:
Component: port/android Version: git master
Severity: Keywords: android, text to speech,


There is already a similar report about this. It's ticket #503 but this is different from the mentioned ticket. I updated my HTC Magic to CyanogenMod? 6 which is based on Android 2.2 When I start Navit I see the usual message "This application can talk using the text-to-speech-library (TTS) Please install the TTS." If I select the install button it opens the market and does a search for "". It shows up no results and of course cannot install TTS. In Android 2.2 tts seems to work different. In the settings there is a menu called "Voice in- and output --> Text-to-speech settings". Under Modules you find a point called "Pico TTS Settings". Here you can select the TTS language that should be installed. It downloads a TTS installer apk then and installs some language files on the SD card if you execute it. The speech examples in the settings work perfectly and sound exactly the same as in Android 2.1 But still the speech output of Navit does not work. I tried it with the latest svn for HTC models this morning. It looks like a seperate version for Android 2.2 is needed. Obviously some TTS related things changed there...

Change History (5)

comment:1 Changed 12 years ago by florian

  • Cc added

comment:2 Changed 12 years ago by florian

I downloaded the latest svn of navit and looked a bit into the code in the android folder. In NavitSpeech?.java there is a line "import;" is the package that Navit searches on the market. It's not available anymore. Then I browsed the documentation of Android 2.2 a bit and found this: It seems that text to speech now is in android.speech.tts I'm not into Android development yet, so I am not able to test around with it. Maybe this helped you at least a bit.

comment:3 Changed 12 years ago by florian

woglinde and sanderd17 on the IRC helped me further with this problem. If you install the TTS package from this page it will work fine!

comment:5 Changed 12 years ago by sanderd17

  • Resolution set to fixed
  • Status changed from new to closed

tts is working on android 2.2 now without the tts app (tested with a cyanogen mod 6 based rom). I think it was solved in this changeset:

Thanks Martin-s

Note: See TracTickets for help on using tickets.