Changes between Initial Version and Version 1 of Ticket #659


Ignore:
Timestamp:
11/09/10 10:34:23 (11 years ago)
Author:
kazer
Comment:

From your first vehicle, it doesn't seem to be enabled. Have you tried to enable it?

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #659

    • Property Owner changed from KaZeR to chollya
    • Property Component changed from core to port/maemo
  • Ticket #659 – Description

    initial v1  
    22
    33Background facts:
    4 1) I have a new Nokia N900 with the latest Nokia official firmware 10.2010.19-1 (PR1.2).
    5 2) I am trying to use navit SVN build 3541 (the latest build for N900 I managed to find) and gtk GUI. I downloaded it from http://www.chollya.org/navit and it was reported to work well.
    6 3) The built in GPS of my N900 works. It received sufficient signal during the test because several other GPS apps (ovi maps, maemo mapper, gpsjini) were able to get an instant fix at the same time when I tried to run navit. All apps _except navit_ showed correct coordinates.
    7 4) The navit installation and configs appear to be correct (except for the <vehicle> tag). No XML error messages appear in the console. I downloaded an OSM map of Moscow through extractor, configured it, and it was shown in the navit window, when I tried to find my home address.
     4 * I have a new Nokia N900 with the latest Nokia official firmware 10.2010.19-1 (PR1.2).
     5 * I am trying to use navit SVN build 3541 (the latest build for N900 I managed to find) and gtk GUI. I downloaded it from http://www.chollya.org/navit and it was reported to work well.
     6 * The built in GPS of my N900 works. It received sufficient signal during the test because several other GPS apps (ovi maps, maemo mapper, gpsjini) were able to get an instant fix at the same time when I tried to run navit. All apps _except navit_ showed correct coordinates.
     7 * The navit installation and configs appear to be correct (except for the <vehicle> tag). No XML error messages appear in the console. I downloaded an OSM map of Moscow through extractor, configured it, and it was shown in the navit window, when I tried to find my home address.
    88
    99Problem:
    1010Navit fails to receive coordinates from GPS. There are two configuration examples for the maemo GPS driver. I tried both with different results.
    11 1) First, I configured it exactly as shown in http://wiki.navit-project.org/index.php/Navit_on_Scratchbox_for_N8x0.
     11 * First, I configured it exactly as shown in http://wiki.navit-project.org/index.php/Navit_on_Scratchbox_for_N8x0.
    1212
     13{{{
    1314 <vehicle name="my n900" source="maemo://any" retry_interval="1"/>
     15}}}
    1416
    1517Navit starts up well and seems stable. The gps icon appears in the status bar indicating that GPS works. But (!) Navit always shows dummy coordinates 0.0000 N 0.0000 E in its own status bar. No messages relating to gps device appear in the console.
    1618
    17 2) Second, I found a sample navit.xml from a user, who claimed that it worked for him on a N900. The vehicle tag looks different there:
     19 * Second, I found a sample navit.xml from a user, who claimed that it worked for him on a N900. The vehicle tag looks different there:
    1820
     21{{{
    1922        <vehicle name="Local GPS" profilename="car" enabled="yes" active="1" source="maemo">
    2023                <!-- Navit can write a tracklog in several formats (gpx, nmea or textfile): -->
    2124                <log enabled="no" type="gpx" attr_types="position_time_iso8601,position_direction,position_speed,profilename,position_radius" data="track_%Y%m%d-%%i.gpx" flush_size="1000" flush_time="30"/>
    2225        </vehicle>
     26}}}
    2327
    2428This fails with an error message: