Opened 10 years ago

Closed 10 years ago

#982 closed enhancement/feature request (fixed)

Separate icon for "Former destinations" in internal GUI

Reported by: sleske Owned by: cp15
Priority: major Milestone:
Component: gui/internal Version: git master
Severity: Keywords:
Cc:

Description

The menu item for "Former destinations" in the internal GUI should really have its own icon. A patch is included with this ticket. See attachment for appearance of the new icons.

It's not the prettiest icon, but at least one icon no longer needs to be shared by Bookmarks and Former destinations.

Attachments (5)

formerdests-icon.diff (17.6 KB) - added by sleske 10 years ago.
Patch to add a new icon for "Former destinations" to the internal GUI
screenshot.png (24.2 KB) - added by sleske 10 years ago.
Screenshot of internal GUI with new icon
formerdests-icon.2.diff (17.6 KB) - added by sleske 10 years ago.
Screenshot-Navit-1.png (40.1 KB) - added by korrosa 10 years ago.
Former destinations icon with a grey background
former_destinations_icon.diff (440 bytes) - added by korrosa 10 years ago.

Download all attachments as: .zip

Change History (15)

Changed 10 years ago by sleske

Patch to add a new icon for "Former destinations" to the internal GUI

Changed 10 years ago by sleske

Screenshot of internal GUI with new icon

comment:1 Changed 10 years ago by sleske

I chose a flag with a clock to convey the concept of "former destinations". I found it rather tricky to come up with a fitting image for the concept of "former destinations", and this was the best idea I found. If someone comes up with a better option, I won't insist on my version :-).

Changed 10 years ago by sleske

comment:2 Changed 10 years ago by sleske

Attachment corrected (use integral width&height in SVG).

comment:3 Changed 10 years ago by sleske

  • Resolution set to fixed
  • Status changed from new to closed

Changed 10 years ago by korrosa

Former destinations icon with a grey background

comment:4 Changed 10 years ago by korrosa

As you can see in the attached screenshot, the former destinations icon has a grey background to it. I think it should be transparent, in-keeping with the rest of the icons!

Changed 10 years ago by korrosa

comment:5 Changed 10 years ago by korrosa

The attached patch fixes it for me. Not sure if pageopacity does much, but certainly setting the pagecolor to black works fine (as you would expect!).

I won't commit this yet, because I presume this won't actually update everyone's icon set if they've already built them before?

comment:6 Changed 10 years ago by korrosa

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Changed 10 years ago by sleske

I won't commit this yet, because I presume this won't actually update everyone's icon set if they've already built them before?

Yes, the Makefile under xpm/ is broken ("make clean" does not work, and "make all" does not re-convert updated source files). I created #1016 to track this.

About the image: I cannot reproduce the problem; for me the icon always shows without a grey background. Maybe the problem only occurs for certain GUIs, or for certain SVG converters.

Anyway, the changed file works for me as well, so feel free to commit it if it helps in some configurations.

comment:8 Changed 10 years ago by korrosa

For completeness: I'm running all this on a netbook with Ubuntu 10.04 (Lucid). I have Inkscape installed (which I think is used during the conversion process, from what I remember). I also have imagemagick installed (though I think this is the fallback option)

comment:9 Changed 10 years ago by korrosa

Commited in r4953.

comment:10 Changed 10 years ago by korrosa

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.